Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer with Windows 8 (x64) won't go to sleep. After I tell the computer to go to sleep the screen fades to black as expected, but just when the computer should "turn off", the fans speed up (as on a cold boot) and shows me my lock screen, as if I was waking it.

As far as I know this have started happening after I installed the free Media Center add-on that Microsoft offered me.

Here's some powercfg that I just fetched after trying to make the computer sleep:

C:\WINDOWS\system32>powercfg /lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

C:\WINDOWS\system32>powercfg /requests
DISPLAY:
None.

SYSTEM:
[DRIVER] \FileSystem\srvnet
An active remote client has recently sent requests to this machine.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

FULLSCREENVIDEO:
None.

I guess it is the [DRIVER] \FileSystem\srvnet An active remote client has recently sent requests to this machine. that is causing the trouble.

Here is what I've tried:

  1. Turning off "Allow hybrid sleep" under Power Options.
  2. Disabling the Media Center in "Windows Features".
  3. Updating the network adapter drivers.
  4. Removed everything except my keyboard with the Powercfg -devicequery wake_armed command.
  5. Tried using powercfg -requestsoverride driver \filesystem\srvnet system (what does this command do?)

How do I continue from here? I've read that blocking media streaming might help, but I can't find it on Windows 8.

share|improve this question
    
Do you have an extender connected to your Media Center? –  Ramhound Mar 5 '13 at 16:48
    
No, I don't use it at all. –  Eikern Mar 5 '13 at 17:17
    
So you never configured Media Center? Do you have the user profile that handles the streaming? Because the log file you posted clearly indicates SOMETHING is connected to your pc. This was a good read and I confirmed the options are still there in Windows 8 ( slightly changed of course ) superuser.com/questions/40596/computer-wont-go-to-sleep?rq=1 –  Ramhound Mar 5 '13 at 17:27
    
I have not set up MC. This is the only account on the computer. The setting isn't there for me. –  Eikern Mar 5 '13 at 18:23
1  
I would uninstall the application that handles Nvidia updates to eliminate the service as the reason for your problems. You don't have the user that handles the media center so doesn't matter. One simple solution would be to disconnect from your network to see if this problem still exists. As pointed out a remote client is causing this problem. –  Ramhound Mar 5 '13 at 20:57

2 Answers 2

Have got same sort of output from powercfg commands. Had a look in "Task Scheduler->Microsoft->Windows->WindowsUpdate", "conditions" tab and it says "wake this computer to run this task". Have turned it off and will see what happens tonight. enter image description here

share|improve this answer

Go to BIOS and disable: wake up on lan! Last time i had that option on and some programs ( Log me in and some other remote and internet programs) that use that option they were waking my computer after half a minute and after I disabled that option, sleep was working fine :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.