Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just upgraded from Linux mint 13 to 14 Cinammon. The problem is I have the tar files of sublime text and eclipse that I usually extract and run but after I upgraded to Mint 14 I get the error in the image whenever I click on the executable.

error

share|improve this question
    
-1: The question is very unclear and ambiguous. No details or examples of what is being done and why. This leaves any attempt to diagnose it impossible. –  killermist Mar 5 '13 at 16:50
add comment

2 Answers 2

up vote -2 down vote accepted

Things you should do:

  1. Try running the command in the console. You may have to first make it executable: chmod +x eclipse in that directory, then ./eclipse. It should work.

  2. Create a menu shortcut to the executable once you get it working in the console. To do this, right click on the Cinnamon menu and do Edit Menu.

Most likely is that Mint's file explorer simply doesn't support executing binaries with no file extension. You could probably set up a file extension association for, e.g. .bin, but some approaches to file association in launcher shells don't account for files with no extension at all.

The reason this question is problematic is that you are not attempting to execute the files in other ways than by double clicking them, so we don't know if there are any further problems that may be preventing the successful launch of the application, like:

  • Permission problems (volume mounted noexec or the file doesn't have execute permission matching your user/group mask)
  • Java not installed; Eclipse requires Java
  • Linkage or other native library problems or versioning problems
  • Other missing dependent packages
  • File corruption

Your comment to my answer did not address any of these concerns, you just repeated "it doesnt [sic] work". Unless you do as asked and attempt to run it through the terminal/console, there is nothing more I can do to help.

share|improve this answer
2  
Why is double-clicking them less secure? –  cpast Mar 5 '13 at 16:47
    
it doesnt work..ive tried setting the permissions through properties as well –  Bazinga777 Mar 5 '13 at 16:51
    
Double-clicking is no less secure. I've never seen a file explorer that would let you launch binary files that were not executable already. –  ssmy Mar 5 '13 at 17:05
    
Alright, for all of you who piled on about my security paragraph, you can un-downvote now. My answer is purely about diagnosing the problem now. –  ÃŁŁǫǛȉЖΦΤїҪ Mar 5 '13 at 18:55
    
Your answer is correct. If I was going to run the executable directly after downloading and extracting, I would have done that first. I have set it as the correct answer, sorry about the down vote though. Can't help –  Bazinga777 Mar 6 '13 at 18:55
add comment

I have fixed it. The problem was that I had the files in another partition. When I moved the files to the Home folder, I could change the permissions and then run the program.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.