Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My topology looks like this:

WAN
    - Router 1 (LAN 192.168.4.1; 255.255.255.0)
        - PC 1 (192.168.4.10)
        - Router 2 (WAN 192.168.4.20; LAN 192.168.3.1; 255.255.255.0)
            - PC 2 (192.168.3.10)

And I need to enable windows file sharing between PC 1 and PC 2. And when I go to "Network" in Win7 Explorer, I want to see my PC 1 and PC 2 there on both computers.

My Router 2 redirects ports 445 and 137-139 to PC 2. This way, I managed to get it working somewhat. I can access the PC 2 from PC 1 by entering IP directly "\\192.168.4.20\". But I cannot access the PC 2 from PC 1 by typing it's computer name, and I also don't see it in "Network". It goes the same when accessing PC 1 from PC 2 ... I can use IP, but not name.

I tried using DMZ on Router 2 but that did not helped one bit. I tried turning PC 2 Windows Firewall off, but that also did not helped. When both computers were connected to the same router, it all worked fine. But the topology changed recently. So how can I get it working again? Thanks.

PC 1 is Win7, PC 2 is WinVista.

share|improve this question
    
Why is your network set up this way?! Why not flatten it? Dual NAT sucks. (Your setup is very broken. How would a packet from 192.168.4.20 to 192.168.3.10 ever get to router 2?) –  David Schwartz Mar 6 '13 at 0:54
    
Because some PCs don't have Wifi and the Wifi router (Router 1) is not accessible by multiple cables. –  Paya Mar 6 '13 at 0:56
    
So why not connect the Internet access to router 2 and use router 1 just as a switch and access point? Or connect router 1's wired port to router 2's LAN port and connect other wired machines to router 2? Or something that makes sense. –  David Schwartz Mar 6 '13 at 0:57
    
Router 1 is also modem, I cannot move it around. To access Router 2 subnetwork, I just need to address Router 2 WAN address ... I need to get running the file sharing and other incoming connections are not required. But I would need to use port redirecting otherwise obviously. –  Paya Mar 6 '13 at 1:00
    
So connect router 2's LAN port to router 1's wired port. Disable router 2's DHCP server. Connect wired machines to router 2's other LAN ports. You will never be happy with a dual-NAT setup. –  David Schwartz Mar 6 '13 at 1:01
show 5 more comments

1 Answer

up vote 1 down vote accepted

Get rid of double NAT. You can use routers as switches and access points by connecting them LAN-to-LAN.

share|improve this answer
    
Related discussion is in the comment section of the question. –  Paya Mar 6 '13 at 21:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.