Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed windows and Linux(ubuntu) on the same machine. Now the problem is when I start my machine, It goes directly to Linux and does not ask me for the selection of OS either I want to load Windows or Linux.

How can I change setting that it ask me for the selection of OS? I guess it is the configuration at bios(machine) level so I asked this question here.

NOTE: I want to know settings for both cases either system directly loads Windows or Linux, what will be the settings to make it selected from user.

share|improve this question

migrated from serverfault.com Mar 6 '13 at 4:30

This question came from our site for system and network administrators.

    
NOTE: this specific note has been crossposted to superuser SE! –  mdpc Mar 6 '13 at 4:23
    
Which version of ubuntu are you running? –  Paul Mar 6 '13 at 4:37

4 Answers 4

It has been a while since I have utilized this, but you would want to research boot loaders. I know that "grub" is one of the names that comes to mind immediately. It provides a graphical interface at boot, After post, for a user to select an operating system. If they don't select one, a timeout occurs and a selected default OS is launched.

share|improve this answer

go to run or search bar in start menu >>> type msconfig >>>> boot tab >>> set your OS boot preferences.

share|improve this answer
    
Right :) and what should I do for Linux as if linux is opening by default? mean where are the boot settings for the Linux –  Despicable Mar 6 '13 at 4:52
    
It's always risky running Linux and Windows side by side. As such, my knowledge and 'experience' is limited in regards to your question. I have always run Ubuntu live CD off a thumb drive or in a virtual environment via VirtualBox. Something to consider if a solution proves difficult to find. –  Josh Campbell Mar 6 '13 at 5:03

hope you are using ubuntu latest version, go to /etc/default and edit file grub you can use any method for editing.use can use this either

gedit /etc/default/grub

you will find list of os,

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs

find the index of your operating system, and replace with x in grub deafult

GRUB_DEFAULT=x

and finally do a

update-grub

in your case, i suppose changing time out in GRUB_HIDDEN_TIMEOUT=0 will solve your issue.

share|improve this answer

Modify the order of OS's in your /etc/grub/grub.conf file like so:

default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux Server (2.6.32-358.0.1.el6.x86_64)
    root (hd0,0)
    kernel /vmlinuz-2.6.32-358.0.1.el6.x86_64 ro root=UUID=9f61352f-55c5-4063-ba3c-7fde39c04175 
    initrd /initramfs-2.6.32-358.0.1.el6.x86_64.img
title Red Hat Enterprise Linux (2.6.32-71.el6.x86_64)
    root (hd0,0)
    kernel /vmlinuz-2.6.32-71.el6.x86_64 ro root=UUID=9f61352f-55c5-4063-ba3c-7fde39c04175 
    initrd /initramfs-2.6.32-71.el6.x86_64.img

Also, 'timeout' is the time in seconds the menu waits for you to make a selection.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.