Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running WinXP in VirtualPC on Windows 7 and the ESC and TAB buttons are no longer working. Has anyone had this problem before?

share|improve this question
add comment

5 Answers

I find that shutting down the Virtual PC, then logging off Windows 7 and back on again, then starting Virtual PC fixes the problem.

For me, it always starts with a mistype, but I can't catch myself doing it, so I don't know what it is I do that sets it off.

I have been running Windows 98 in a Virtual PC for many years with no real problems, in Windows XP and now Windows 7.

share|improve this answer
add comment

If you already have a software allow policy and the tab button still doesn't work, try opening the %AppData%\Roaming\Microsoft\Virtual PC\Options.xml file and searching for the following:

<configuration>
    <language>
        <override>
            <filename type="string">English.dict</filename>
            <id type="integer">128</id>
        </override>
    </language>
</configuration>

Removing this section from Options.xml seems to fix the problem without messing with your configuration too much.

share|improve this answer
add comment

You can edit the file Option.xml with notepad find the section :

/keyboard\
    /host_key_code type="integer"\ (you host key code) //host_key_code\
//keyboard\

Remove the line talking about multi key if exists, it'll solve the problem.

I'm still looking for what sets the multi key option...

share|improve this answer
add comment

Had this same problem. I could not get the above to work, however, I did find a solution.

  1. Shut down Virtual PC after shutting down any running virtual machines.

  2. Open Windows Explorer.

  3. Type %AppData% in the address bar and press Enter.

  4. Navigate to the path Roaming\Microsoft\Virtual PC under the %AppData% folder.

  5. Locate the file Options.xml in the above folder and delete it.

  6. Restart Virtual PC and the misbehaving virtual machine and note that the Escape, Tab and other keys are now working.

NB: The issue will occasionally reappear requiring the above process to be repeated. Needless to say, that is irritating.

Source

share|improve this answer
add comment

This may be of interest

If you are running into this issue on Vista and Windows 7 you can get the TAB key back by creating a software allow policy. Go to administrative tools, local security policy, Software Restriction Policies, Additional Rules. Create a new rule for %appdata%\microsoft\vritual pc\vpckeyboard.dll and set it to Unrestricted. Restart Virtual PC.

If the variable doesn't work, try using an explicit path i.e. c:\users\username\appdata\roaming\microsoft\virtualpc\vpckeyboard.dll

Link to source

share|improve this answer
    
I've been experiencing the same problem, and I can report that this workaround does NOT work. Any other suggestions will be appreciated! –  Andrei Belogortseff Dec 12 '09 at 0:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.