Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new HP Z800 Workstation, running Windows 7 Enterprise 64 bit. Z800 Specs are here.

The machine has 4GB of RAM -- windows reported 1.99GB available, 2GB was "hardware reserved". I added another 2 GB and windows reports that there is 6GB of physical RAM, but now 4GB is "hardware reserved". The BIOS sees the full RAM amount as well.

The video card is an nVidia Quadro FX 580, so it shouldn't be using any shared memory at all.

Why is all my extra RAM marked as "hardware reserved" in Windows 7?

share|improve this question
up vote 27 down vote accepted

Turns out that the installed RAM was in an unsupported config -- On this machine, if you install 2GB chips, they have to be installed in triple, as referenced here (pdf).

Its interesting to note that Windows saw the memory, but it was rendered not usable and marked as "hardware reserved".

share|improve this answer
7  
+1 Very interesting. :-) – Mehrdad Apr 4 '11 at 3:26
    
@ericvg English doc? – Mugen Apr 27 '15 at 15:59

Ouch, sad to hear about the re-install.

There is a great Mark Russinovich Blog post that explains how windows uses physical memory.

  1. Hardware devices can reserve large blocks of physical address space... To see if a piece of hardware is reserving a large chunk of physical address space, launch "devmgmt.msc", select Resources by Connection in the View Menu, and expand the Memory node. (Mark's blog explains this further.)

  2. Even though your video card has onboard, fast, dedicated video memory, Windows still has to address and interact with that memory using the same physical memory addressing that is uses for RAM, PCI devices and other devices. This can crowd the physical address space. 64 bit OS should cope better with this than a 32 bit OS, but its hands may still be tied some device requirements.
    (My Dell has 700 MB hardware reserved on Win7x64. It's not nearly as bad as your issue, but still annoying.)

  3. It would be helpful to know if a tool like memtest (which boots and runs without windows) can see all of the installed RAM. Try some of the system info tools on the UBCD to see if they can see (and test) all of your RAM. This would let you know if Windows has even has anything to do with it.

As a final thought, you bought it new from a major vendor, you should be able to get a support from them, and ask them about the issue. They can often get to the bottom of this sort of issue much faster than searching around on the internet, and you've already paid for this service.

Edit: this SO question may be related to your issue, and there is another good explanation of the how memory-mapped IO reservations can reduce the usable RAM. Again, this may not be exactly the problem you are facing, but those blogs tell you how you can determine if it is.

Let us know.

share|improve this answer
    
+1 for the UBCD link -- going to try that now. – ericvg Nov 2 '09 at 18:03

I had this same issue and have fixed it on my particular machine. I was showing 4G reserved in HW. I went into the MB BIOS and under chipset configuration/ internal graphics/

I changed the setting for Frame Buffer Location from [Above 4G] to [Below 4G}... and now i have 1MB in HW reserved and not 4G. Windows sees all *G as usable

share|improve this answer

I have this exact problem fixed! With Gigabyte p55a ud3r and Kingston KHX1600C9D3K4/8GX.

When you buy RAM, you get it in pairs, as it turned out each pair/memory stick can only work on memory channel 1 or memory channel 2.

If you put a pair of memory that designed to work only on channel 1, on channel 2 (like I did unknowingly). The BIOS only recognizes them, "BUT" not made available to use. Windows 7 can only see the total RAM installed (in my case 8 GB), but can't make use of the other 4 GBs on memory channel 2, and Windows 7 thinks the 4 GB memory are "HARDWARE RESERVED".

So I advise you to switch them up between the memory slots, like I did, and now I only have 5 MB HARDWARE RESERVED instead of 4 GB like before when I put the RAM sticks on the wrongs slots/channel.

share|improve this answer
    
Do you mean to say that you merely interchanged the RAM sticks? Could you please explain what do we mean by memory channels here? If my motherboard has 2 DMMI slots then are those channel 1 and channel 2 respectively? – Mugen Apr 27 '15 at 16:13

Maybe updating BIOS would help? Also, try enabling Memory Remaping in BIOS, or something like this, if you manage to find it in your SETUP.

share|improve this answer
    
Also, I found out, that the HP Z800 comes with 2GB of RAM by default... Maybe HP just don't want users to add more? Silly, I know... :) – sYnfo Oct 16 '09 at 15:51
1  
According to the specs, that model can actually support 192GB if the O/S and other hardware allows it – MartW Oct 16 '09 at 16:22

I had a similar problem with a Samsung R519. In my case I upgraded from 2gb to 4gb RAM but I only have a 32bit OS on my machine. So in my case that is the limiting factor as 32bit OS will only see 3gb max.

share|improve this answer

For anyone still having this issue:

  1. Press Start -> Run

  2. Type msconfig

  3. Go under the "Boot" tab

  4. Click "Advanced options" button

  5. Uncheck "Maximum memory"

    enter image description here

  6. Reboot

Helped for me, got still reserved only 9 Mb from totally of 6 Gb.

share|improve this answer

There's actually a big clue in the message: "Hardware reserved".

If checking/unchecking the "Maximum memory" checkbox under Windows isn't helping, the culprit may be the default BIOS settings, which can reserve excessive RAM for graphics hardware.

In my case, Windows reported that 1.1G of my installed 8G RAM was "hardware reserved":

"Hardware reserved" before BIOS setting change

I fixed it by changing the BIOS setting. The naming or menu details may be different in your BIOS, but here's the story in my case. Under the Advanced settings, go to Advanced Chipset Configuration:

BIOS settings

Under Advanced Chipset Configuration is a setting called UMA Frame Buffer Size. This controls how much of your RAM is reserved for your graphics hardware, and by default may be set to Auto, which will decide an amount based on how much RAM you have installed and—depending on your needs—may reserve far more than necessary:

BIOS settings

http://www.errorteck.com/good-to-know/computer-terminology/how-to-get-more-performance-from-a-laptop-computer.html

For general use, set it to 256M:

BIOS settings

enter image description here

The result in Task Manager:

"Hardware reserved" after BIOS setting change

share|improve this answer

protected by random Sep 19 '12 at 0:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.