Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I closed all applications and then chose to install the Performance Update that was released this week (October 16, 2009). Upon rebooting I get a blue screen with the gray and black waiting circle. Is it safe to just hold down the power button until the system shuts off and the restart?

share|improve this question
    
Update I waited for 10 minutes and the system just stayed at the blue screen with the grey and black waiting spinner, so I held the power button down for 5 seconds and restarted the system. Upon restarting (which took much longer than normal), the Bluetooth is not available. I rebooted again and Bluetooth is still not available. –  Matthew Rankin Oct 16 '09 at 14:24
2  
If Bluetooth is not available, try doing an SMC reset. It might sound like voodoo, but it worked for me. See support.apple.com/kb/HT1411 –  Olly Hodgson Oct 16 '09 at 14:35
    
Thanks to Jared Harley for fixing all my typos. I'm clearly not an expert typist when forced to submit questions to SuperUser from my iPhone! –  Matthew Rankin Oct 16 '09 at 14:58
    
@Olly: You might want to make that an answer instead of just a comment. –  Chealion Oct 16 '09 at 15:00
    
@Olly: Please make that an answer, as that was the answer to solving the Bluetooth problem. The boot time still seems a little longer than what I'm used to, but I'll review the logs with Console to figure what's up there. Thanks again. –  Matthew Rankin Oct 16 '09 at 15:07
show 1 more comment

3 Answers

up vote 3 down vote accepted

If Bluetooth is not available, try doing an SMC reset. It might sound like voodoo, but it worked for me. See support.apple.com/kb/HT1411

share|improve this answer
add comment

Try booting with v pressed (verbose booting); maybe you'll spot something there. This might be a first step in diagnosing your problem. What's weird is that the performance update had nothing to do with bluetooth, it was hard drive related. You probably corrupted a file when you powered off the machine.

share|improve this answer
    
I tried booting with v pressed but didn't receive anything. I agree that the update didn't cause the bluetooth problem, except that the update didn't perform correctly, so I bet you're correct that something was corrupted during the process or when I powered off (although I can't believe that the update should take longer than 10 minutes). –  Matthew Rankin Oct 16 '09 at 15:09
add comment

The performance update was to do with the issue where hard drive read would stall. I don't see how it could have affected the bluetooth.

However, turning off the machine during boot could have resulted in damaging a file related to bluetooth.

I would recommend restoring your Mac to a backup (Time Machine, or otherwise) taken just before you installed the update.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.