Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We are deploying computers offsite to several sites in small workgroup (i.e. non-domain) environments. The computers have a single network card and no loopback adapter.

The problem is that when we ship the PCs and they connect to their new network, Windows defaults to Public Network and wants me to set the Network Location. Until this is set we cannot connect remotely.

What I need is a way to force it to always select "Work Network".

I tried this: Force network location to "Work network" in Windows 7 (with a reboot after applying) but the Network And Sharing Center still shows "Public Network" when I connect to a new network.

Also, to repeatedly test this, how do I delete the list of networks already connected to, to force Windows to re-analyze a network connection the next time I connect?

Using Windows 7 Professional SP1

share|improve this question
    
@Chake: Thanks for the second bit, but the (Work/Private Netowrk) setting needs to apply to a unknown network they will connect to in the future. –  Lensman99 Mar 22 '13 at 12:16
    
That is to say, essentially I need Windows to treat all future networks as Private. The Group Policy settings only apply to networks that cannot be identified or networks that are in the process of being identified, not Identifiable networks. –  Lensman99 Mar 22 '13 at 12:23

3 Answers 3

You can define the behaviour via local Group Policy:

Open "gpedit.msc" -> Go to Computer Configration –> Windows Settings –> Security Settings –> Network list manager

Here you will find your desired options.

I wasn't able to test you second question, but found the following link: http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/how-do-i-delete-or-clear-redundant-network/07834191-708d-45f9-9ef2-e779dd930ce3

share|improve this answer

OK so here's how I solved this.

The main difference between Work Network (AKA Private Network) and Public Network is that a different set of firewall rules are used. So instead of trying to change the Network Location to Work Network in a script that I would have to walk the customer through finding and running, I just set the Work Network firewall exceptions to apply to Public Networks as well, so we can connect remotely and fix it ourselves.

How To: Click Start - Search for "Firewall" - Inbound Rules - Double click rule - Advanced tab - Under Profiles tick all relevant boxes.

Thanks for you help.

share|improve this answer
    
Is it correct etiquette to mark my own answer as the right one? –  Lensman99 Mar 25 '13 at 16:34
    
yes, you may accept your own answer –  Wouter Huysentruit Jul 11 '13 at 6:44

To answer the second part of the OPs question, I am able to clear all of the "learned" and collected networks that Windows is holding on to. I created this .reg file so that I can test the Public/Private defaulting. This will purge ALL of the learned networks so you can test.

Windows Registry Editor Version 5.00

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\Managed]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\Unmanaged]


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\Managed]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\Unmanaged]

In case you're going blind staring at this: it's deleting three keys and then re-creating them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.