Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently I have only "doubleQuotes" highlighted but the 'single ones' stay normal. Can someone confirm? Or have a solution how to fix that?

In the stylers.xml there is WordsStyle named STRING which has the "doubleQuote" color. But neither there nor in the langs.xml I'm able to see a way to make it work for 'singleQuotes' too. Or at least I know too little to about configuring those Notepad++ files.

Please don't suggest another editor ;] thx!

share|improve this question

migrated from stackoverflow.com Mar 6 '13 at 17:53

This question came from our site for professional and enthusiast programmers.

    
go to language in the top manu and make sure python is selected – Ionut Hulub Mar 6 '13 at 16:37
    
@BurhanKhalid: didn't know the page. Here are similar questions where you didn't suggest this yet. ;] – ewerybody Mar 6 '13 at 17:50
    
@IonutHulub: is already triggered by .py extension :/ Also: The python specific coloring for "doubleQuotes" works! – ewerybody Mar 6 '13 at 17:55
up vote 1 down vote accepted

In the default language styling that comes with Notepad++:

  • 'single' quotes are controlled by the CHARACTER Style
  • "double" ones by STRING.
share|improve this answer
    
Seems there is no way to unify them tho :/. However. Works properly now. – ewerybody Oct 22 '13 at 13:54

on the menu bar, select settings / Style Configurator / Python. then work on the TRIPLE and TRIPLEDOUBLE settings.

share|improve this answer
    
hmm.. No. What you mean does the '''comment block stuff''' thats used for .__doc__ Thats all set up properly. – ewerybody Oct 22 '13 at 13:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .