Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used to use liberation mono font on emacs (on X11) on an Ubuntu system using the following command and it worked great:

(custom-set-faces
  '(default ((t (:inherit nil :stipple nil :background "lightgrey" :foreground "gray20" :inverse-video nil :box nil :strike-through nil :overline nil :underline nil :slant normal :width normal :height 120 :family "liberation mono"))))
  '(background "blue")
  '(font-lock-builtin-face ((((class color) (background dark)) (:foreground "Turquoise"))))
  '(font-lock-comment-face ((t (:foreground "darkred"))))
  '(font-lock-constant-face ((((class color) (background dark)) (:bold t :foreground "DarkOrchid"))))
  '(font-lock-doc-string-face ((t (:foreground "lightblue"))))
  '(font-lock-function-name-face ((t (:foreground "blue"))))
  '(font-lock-keyword-face ((t (:bold t :foreground "steelblue"))))
;  '(font-lock-keyword-face ((t (:bold t :foreground "CornflowerBlue"))))
  '(font-lock-preprocessor-face ((t (:italic nil :foreground "CornFlowerBlue"))))
  '(font-lock-reference-face ((t (:foreground "DodgerBlue"))))
  '(font-lock-string-face ((t (:foreground "Aquamarine4")))))

It looked like this:

enter image description here

Our system admin upgraded to a new release of Ubuntu and now the font looks completely different in emacs. It doesn't look anti-aliased anymore, appears "less bold" and looks like this:

enter image description here

I'm trying to get it to look like it did before. Basically I want a font appearance that looks as close as possible to the Monaco fixed width font on Mac OS X, which on my terminal looks like this:

enter image description here

How can this be done? Ideas? Cannot figure it out. thanks.

share|improve this question

3 Answers 3

You could always use the monaco font:

  1. Create a new fonts directory

    sudo mkdir /usr/share/fonts/truetype/mine
    
  2. Get Monaco.ttf

    sudo wget http://usystem.googlecode.com/files/MONACO.TTF -O /usr/share/fonts/truetype/mine/MONACO.TTF
    
  3. Update your font cache

    fc-cache -f -v   
    
  4. Tell emacs to use the Monaco font. Add this line to your ~/.emacs:

    (set-default-font "monaco")
    

    Personally, I prefer it a little smaller than it appears with the default setting above, so I use

    (set-default-font "-apple-Monaco-normal-normal-normal-*-14-*-*-*-*-0-iso10646-1")
    
share|improve this answer

You could try using the lower-level set-frame-font.

(set-frame-font "Liberation Mono-14:antialias=1")

Change the 14 to whatever size you want. The antialias option should be self-explanatory; 1 for on, 0 for off.

You could also use things like Liberation Mono-bold-14:antialias=1 for bold text (or Liberation Mono-14:weight=bold:antialias=1.

If your height of 120 (in your original config) is important, add :height=120.

More detailed info in the official manual, although it looks like it doesn't list all the options.

share|improve this answer
    
thanks but on second thought I'm not sure the original font I am aiming to use was Liberation Mono. It could be that the system defaulted to monospace or whatever the default system font, which emacs does. I'm just trying to achieve the exact same font as the screen shot above. Do you know which font it is? –  user46976 Mar 9 '13 at 15:36
    
I guess it could have been DejaVu Sans Mono; that's a pretty common default mono font for Linux distros. The screenshot you have up there really looks like Liberation Mono, though. If you have access to an environment where it works as before, you can use M-x describe-font to find out for sure. There are other problems it could be, though. Perhaps the font you had isn't installed by default anymore; there's a good chance this upgrade was from 10.04 LTS to 12.04 LTS, and the former is one release before the new Ubuntu fonts were added. (I don't use Ubuntu, so not entirely sure on this info.) –  qmega Mar 10 '13 at 3:40
    
If what you really want is Monaco, is there any reason you can't just copy that from your OS X box and install it user-local on this system? –  qmega Mar 10 '13 at 3:44
    
on my mac box I see /System/Library/Fonts/Monaco.dfont - don't I need it in .ttf format to use on ubuntu? If so, how can I convert it to ttf or find the ttf version on my mac? –  user46976 Mar 10 '13 at 15:42
    
dfont is actually a container for TrueType fonts, so you just need to extract them. Fondu will do that for you. –  qmega Mar 10 '13 at 20:09

It's been over six months since you posted your question. It's not clear that you found the answer.

See this page on Emacs Wiki: SetFonts. It has everything you need to know about displaying installed fonts to choose from and choosing one for Emacs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.