Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently I have 3 network drives I mount each time i restart my system. The command I use is:

sudo mount -t cifs //192.168.1.8/ARES /media/Ares -o user=USER,password=***
sudo mount -t cifs //192.168.1.8/ATHENA /media/Athena -o user=USER,password=***
sudo mount -t cifs //192.168.1.8/PLUTO /media/Pluto -o user=USER,password=***

I would love to add these puppies over to fstab so I did some googling and came up with this gem: http://www.cyberciti.biz/faq/configure-a-system-to-automount-a-samba-share-with-etcfstab/ the issue is my system refuses to see smbfs as a valid type, and boot fails. What is the correct way to mount samba shares via fstab as cifs?

I had tried:

//192.168.1.8/PLUTO /media/Pluto      cifs   username=USER,password=** 0 0

but this also resulted in a failed boot.

EDIT

I guess i could put them all in a bash script, and run the bash script on system boot....but that seems like a crappy work around

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I have a wiki page which deals in details about Samba mount, either using the smbfs or cifs file system type.

I do not see any error in what you tried. Perhaps you could try to use smbfs instead of cifs, take care that the options might be slightly different! smbfs is the deprecated SMB filesystem in the Kernel, it is still here around for historical reason. You should keep on using cifs which is the supported filesystem.

In addition, I recommend to use the credentials option, so you can put the password in a safer place than fstab which is often world readable!

Finally, you do not need to reboot to test your /etc/fstab changes. Simply umount your share (if it is mounted) and mount it again by typing:

mount /media/PLUTO
share|improve this answer
    
** "world" readable, not "word" readable... some people just might get confused... –  kalaracey Mar 13 '13 at 13:21
    
@kalaracey thanks for spotting the typo, this is now corrected. –  Huygens Mar 13 '13 at 13:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.