Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows (at least XP and Vista, I haven't tried 7) refuses to honor my setting of the icon to show for html files. It insist in showing the paper sheet with the IE logo on it.

On XP I changed the icon through Folder options > File Types and for Vista I used FileTypesMan. But it does not work at all.

How can I do this?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

An application could have installed an Icon Handler to provide a custom icon depending on file contents. For example, Microsoft Office installs icon handler to display custom icons for HTML files created in Word or Excel.

If there's an Icon Handler, Windows wouldn't use icon from DefaultIcon.

So try to remove the key:

HKEY_CLASSES_ROOT\htmlfile\shellex\IconHandler

Then Explorer will use icon specified in DefaultIcon:

HKEY_CLASSES_ROOT\htmlfile\DefaultIcon

There's no need to restart Explorer. If the icon does not change immediately, then restart Explorer.


Otherwise grvanchal provided steps to change the icon.

share|improve this answer
    
This works, but it breaks existing functionality, i.e. those files meant to show a custom icon will show the default instead. The Icon handler has its own default icon (which is different from the Windows' default), is it possible to set somewhere else the Icon Handler's default? –  GetFree Mar 11 '13 at 20:32
    
@GetFree I guess there's no easy way around it: you either have the Icon Handler or not. If there's an icon handler, it has the full control over the displayed icon. The handler DLL from MS Office 2007 has no icons in it. I'm pretty sure, there are no icons in the handler DLL in subsequent Office versions so it extracts the icons from other files. One can think it should use the DefaultIcon setting where customized icons are not applicable. And I agree. But that doesn't seem to be the case. –  Alexey Ivanov Mar 12 '13 at 14:23
    
@GetFree I don't know from where Office extracts the icons. If you find that DLL or EXE, you can modify the default icon to something else. You can use Process Explorer to see which files the Icon Handler opens. However it wouldn't be an easy task since Explorer uses many shell extensions. –  Alexey Ivanov Mar 12 '13 at 14:26

The values for icons are located in registry.

Go to RUN and type regedit

Go to HKEY_CLASSES_ROOT\.html

Then check the default. For example I have chromium browser So my default key is ChromiumHTM.

Go to the name of key in default:

HKEY_CLASSES_ROOT\{YOUR DEFAULT BROWSER KEY}\DefaultIcon

Example:

HKEY_CLASSES_ROOT\ChromiumHTM\DefaultIcon

Change the default value for that key to desired icon. Restart explorer.exe and your icon is changed.

share|improve this answer
    
The default type says htmlfile. I went to that key, and under DefaultIcon is the exact path I set myself with FileTypesMan. –  GetFree Mar 6 '13 at 21:24
    
Did you kill the process and start the explorer.exe or restart? –  grvpanchal Mar 6 '13 at 23:41
    
Yes, I restarted, but it didn't work. –  GetFree Mar 7 '13 at 3:43

A solution from link

Right click Desktop, go to Properties>Appearance
Click "Advanced", choose "Icon" and change size to something other than it's current size.
Press "OK" to confirm changes in all relevant dialogue windows.
When the icons have changed, restore the size to its original value.

This should force a redraw of all icons, clearing the old images.

share|improve this answer
1  
The problem is not the icon cache. I used TweakUI to rebuld the icons, but they stay the same. –  GetFree Mar 6 '13 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.