Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 Ultimate machine that was upgraded to Windows 8 Pro. There's a recurring issue that's preventing IIS from serving a folder tree. After some experimentation, I think I found the underlying issue, but need help understanding what's causing this.

I have a folder off the root of one of my computer's drives that's set to not inherit permissions. I set it to give the user 'IIS APPPOOL\DefaultAppPool' read access. I can confirm the changes take effect, as IIS then is able to serve the contents of this folder and its subfolders.

When I reboot, the IIS user's rights are removed from the folder. The same happens if I try granting access to the IUSR user or IIS_IUSRS group instead. IIS is no longer able to access the folder. What's causing this? It started after upgrading to Windows 8.

I tried to audit permissions changes to see if I could track the change. I followed this guide, and found no Event ID 560 entries in my Event Log. But the IIS Apppool user is still getting removed on reboot.

Answers to some questions :

1. Are you serving this website on the internet or on an Intranet?

Intranet, users access it simply by going to http://computername/.

2. Are you connected to a Windows Domain?

Nope.

3. Have you tried adding the IUSR account to the folder permissions?

Yes, same result.

4. Is this site being hosted as a virtual folder or an application?

I don't believe it's configured as either a Virtual Folder or Application. The site is the Default Web Site. I configured it so its Physical Path is the base folder of this folder tree. When I click 'View Applications' or 'View Virtual Directories', I'm presented with an empty list.

5. What if you change the permissions, then boot into Safe Mode?

This seems to prevent the issue from recurring. When I boot into Safe Mode, the issue doesn't recur, the changed permissions stay changed. However, upon booting back into non-Safe Mode, the issue recurs.

share|improve this question
    
This is likely because of a change in the version of IIS that is now used by Windows 8. Verify your using the same version as you were using I would put money down on the fact there not the same. –  Ramhound Mar 7 '13 at 9:28
    
@Ramhound Umm, I'm using the version that's built in to Windows. The errors I'm getting have an HTML page title of 'IIS 8 <something>', so AFAIK, I'm now on IIS 8. –  Keen Mar 7 '13 at 15:39
    
I know your using IIS 8, so were you using IIS 8 before when it was working, if so then some change between IIS 7.5 and IIS 8 is the cause. You will need to use virtual machines to determine the cause of this problem. –  Ramhound Mar 7 '13 at 15:53
    
@Ramhound It started after upgrading to Windows 8. AFAIK, IIS should be irrelevant to the issue of folder permissions changing. I only included it to be thorough in case it was relevant. Unless you can point me to some documentation that shows that IIS is known to change permissions? –  Keen Mar 7 '13 at 16:01
1  
@pnuts I have been doing so. No one has pointed out how IIS' configuration would be remotely relevant, so I haven't added those details. –  Keen May 13 '13 at 20:10
show 7 more comments

1 Answer 1

As you say that this problem does not happen when booting in Safe mode, then this is not a problem with Windows, so it is some installed product that plays with the permissions.

Use for example autoruns to turn off startups in bunches to find out which one is responsible for it. I would start with security products such as suites, then Explorer add-ons and so on.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.