Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm not using XFCE as a desktop environment, but I am using XFCE's terminal. Currently, when I press F1, I get the help. I really don't need this, and it's really annoying when I accidentally press it when in VIM when trying to press escape.

I didn't see anywhere in Preferences to change/disable keyboard shortcuts. Is there some hidden way to disable these shortcuts?

If it matters, I'm running xmonad on Arch Linux.

share|improve this question
up vote 4 down vote accepted

This page recommends adding blank accellator shortcuts to ~/.config/Terminal/terminalrc'. I run XFCE 4.8 and could not find this file myself. However, in my terminal preferences (under Edit), there is a shortcut tab. Help = F1 is the last shortcut in the list. My terminal emulator version is 0.4.8. Hopefully one of these will be applicable to you.

share|improve this answer
3  
Hmm, doesn't seem to work for me. I'm running xfce4-terminal 0.6.1 for Xfce 4.10. I don't seem to have a shortcut tab... weird... – tjameson Mar 7 '13 at 5:13
2  
If I read correctly, then apparently if you however the mouse over the menu option for help, and press a new key, it will rebind to that key instead and free up F1. link. Seems dubious but it is worth a try. – washbow Mar 7 '13 at 5:21
    
Post #5 here suggests editing ~/.config/xfce4/terminal/accels.scm – washbow Mar 7 '13 at 5:22
2  
That dubious link seemed to work. I had to restart X, but I was able to delete the shortcut. Thanks! – tjameson Mar 7 '13 at 5:31
1  
Under ubunto 14.04 I found the config file under .config/xfce4/terminal – Edward Falk Jun 30 '15 at 18:49

Copied from http://xfce.10915.n7.nabble.com/Function-Keys-binding-in-Xfce-Terminal-tp42414p42417.html

Found on http://docs.xfce.org/faq So what you can do for this specific case:

  1. Run xfce4-appearance-settings, go to Settings and activate Enable editable accelerators.
  2. In XFCE Terminal click Menu/Help, then hover to 'Contents' (move mouse pointer to, but do not click a mouse button). A full line there should read something like '(?) Contents F1'.
  3. Then press 'Delete' at the keyboard.

'F1' should disappear from the menu item.

An accelerator for terminal's fullscreen -- F11 -- can be removed a similar way:

Go to Menu/View/Fullscreen, then press 'Delete'.

Anything else than 'Delete' reassigns to another accelerator button.

share|improve this answer
    
This is an awesome tip. Thanks! – cherio Jul 9 at 1:38

on xubuntu 12.04 with xfce4-terminal 0.6.1 (Xfce 4.10) I've resolved adding:

in ~/.config/xfce4/terminal/accels.scm

(gtk_accel_path "<Actions>/terminal-window/fullscreen" "")
(gtk_accel_path "<Actions>/terminal-window/contents" "")

and in ~/.config/xfce4/terminal/terminalrc

AccelFullscreen=
AccelContents=

so both F1 help/contens and F11 fullscreen are disabled

share|improve this answer
3  
Editing accels.scm alone works for me (version 0.6.1 on Arch). – lilydjwg May 8 '13 at 5:13
    
On Xubuntu 13.10 using xfce4-terminal 0.6.2. I created accels.scm with content above, not changing terminalrc, then closed all opened terminal windows. Then launching a new terminal window had the expected behavior: now F1 is passed to applications (e.g. mc). – Stéphane Gourichon Jan 6 '14 at 10:00

Creating an accels.scm file also worked (without changes to terminalrc) in Xubuntu 13.04. Not sure why!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .