Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have setup a samba share like this:

    [shared]
    path = /home/shared/
    comment = shared
    public = yes
    writable = yes
    printable = no

I can access it from windows, but when I upload files to it, the files I uploaded have the following permission:

-rwxr--r-- 1 nobody nobody 899381 Mar  7 11:59 letter17.rtf

What I would like to see is that, when a user accesses this share, the user acts as if he was a particular user of the samba server(say dave). So that he has access to files that 'dave' has access to, and the files he uploaded belongs to 'dave'.
which option do I use to achieve this?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

In the Samba global configuration you need to specify the guest mapping. It seems that on your installation this guest mapping is mapped to nobody.

Edit your smb.conf file and add something like the following in the [Global] section:

guest account = dave

Replace dave by whatever you want.

share|improve this answer
    
just tried it out. works like a charm. Thank you. :) –  David Dai Mar 7 '13 at 7:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.