Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Office word 2010, when I want to create a new style, under the paragraph section the direction (left-to-right and right-to-left) is disabled. Can I modify the direction then?

Added for mahmoud Mahmoud, if this doesn't apply to you then roll the question back.

Mahmoud has said that he has set the language..It's likely he is referring to a problem for when copy/pasting. as one then sees it comes out the wrong way, and would want to perhaps select the paragraph and look for a left to right or right to left option. This problem doesn't exist for typing it in. But there is a problem for copy/pasting.

Even technet has no solution for that problem-

http://social.technet.microsoft.com/Forums/en-US/word/thread/d38abe4d-bd53-4b18-bfee-e92633ad4df5

Using Hebrew as an example to demonstrate the problem mahmoud is having.

I have added a right to left language, and chosen it. For example, suppose I want to copy and paste this text from this webpage.

http://www.mechon-mamre.org/i/t/t0.htm תורה נביאים וכתובים

Whether it is aligned right or not doesn't matter, but that is how it should look. The first four letter word of that sentence תורה should be on the far right of the sentence. And it is displayed correctly on superuser and on that mechon-mamre site when displayed in a browser e.g. chrome. The long word וכתובים should be on the far left of the three words because that's the last word.

If one adds and chooses Hebrew or Arabic as a language. And i'll use Hebrew for the example

enter image description here

Whether aligning left or right, the first word תורה which should appear on the far right, (as in a right to left language, the first word is on the far right), it is not appearing on the far right, it's appearing on the left, in Ms Word 2010

I've added some buttons to try to resolve this.

File..options..customize ribbon.. Chosen "all commands" in the first dropdown menu. i've chosen "new group" in the right hand side and added 3 commands related to right and left. enter image description here

They appear in my ribbon in Ms Word.

And as you can see i've added the language as you see from my Taskbar.

But Ms Word 2010 isn't letting me make it right to left.

According to an Ms MVP this problem has not yet been fixed http://social.technet.microsoft.com/Forums/en-US/word/thread/d38abe4d-bd53-4b18-bfee-e92633ad4df5

enter image description here

share|improve this question

3 Answers 3

From the Microsoft article, "Right-to-left language features":

If you are using Windows Vista or Windows 7, before you can use any of the right-to-left features in Microsoft Office, or even correctly display right-to-left scripts, you must Add an input language and enable the keyboard layout for the right-to-left language.

share|improve this answer
    
yes it is already enabled –  mahmood Mar 7 '13 at 8:37

I can't test it I'm afraid but I strongly believe the solution is here:

If your computer doesn’t have a right-to-left language version of Office installed, you will need to install the appropriate language pack. You must also be running a Microsoft Windows operating system that has right-to-left support— for example, the Arabic version of Windows Vista Service Pack 2 — and enable the keyboard language for the right-to-left language that you want to use.

share|improve this answer

There are two things to do.

This is besides installing the language.. and if even necessary, adding the extra buttons to word as done in the question, (perhaps not adding the keyboard/language can be a cause) but even with the language added, the problem does or can still occur, and doing the following resolves it.

Update - It does look like when doing step 1 (which I recommend is done), then while you can use <pre> tags and it may work for you.. e.g. you copy/paste it in ms word 2010 and it comes out correctly. Sometimes when i've tried to then copy/paste from ms word to ms word, and one time recently, it went bad. So, it looks like using <h1> tag, ensures it works out. it's possible <h2> might work and consistently. But <h1> i've found thus far, to work fine.

Introductory Summary of First step, If you do the first step, you can skip the second and third steps. This first step also has the advantage that the text doesn't have to be a heading. This first step can be skipped in some cases(like if copy/pasting from a webpage in chrome, you already have the "keep source formatting" option when pasting int ms word). This first stage is a way of ensuring you get that "ctrl-keep source formatting" option if you were to paste into ms word! If you already have it, then you can skip this step.

Introductory Summary of Second step, Having that "keep source formatting" option appearing in Ms Word 2010 when you paste. If you already have it then you could skip "First". The second step isn't really so much a step. Just verifying that you get the "keep source formatting" option. And you can actually start at this stage, though then you have to also do step three.

Introductory summary to third step, make it a heading "Heading 1" and by clicking Heading1 two or three times!

Note- Clicking "Heading2" doesn't do the trick. It has to be clicking "Heading1"!

If you skip step 1, you may need to do both steps 2 and 3 to get it to work.

If you follow step 1, i've found you can skip steps 2 and 3 and don't need the hebrew to be a heading either.

First thing to do

This stage can in some cases be skipped. First try "Second" that is, copy it from where it is, and paste it into Ms Word. See if you get a "ctrl..keep source formatting" option
keep source formatting

If you do, continue to "Second". If not, then

i'd suggest, and this is the first step, that you have to copy from Chrome, which means put your text into a particularly formatted HTM file and open it in Chrome.

Here is an HTM file that you can use. I mention this in the Second step

makehebrewcorrectway.htm Save this in notepad as UTF-8 . Note the charset in the meta tag as UTF-8. Also the extra stuff in the HTML tag.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML DIR="RTL" LANG="HE">
<HEAD>
<meta http-equiv="content-type" content="text/html;charset=UTF-8">
</HEAD>
<BODY>
<H1>תורה נביאים וכתובים</H1>
<PRE>תורה נביאים וכתובים</PRE>
</BODY>
</HTML>

Now open it in Chrome, do CTRL-SHIFT-I right click the opening <HTML..> tag or closing </HTML> tag, and click "Edit as HTML" and you can conveniently edit the file and paste Hebrew into it, and the webpage updates itself.

You can then copy/paste from the webpage.

Any Hebrew you write or paste in, within the <PRE>..</PRE> tags, will come out plain(not big/bold).

Second thing to do: Choose keep source formatting

Here are two webpages, if you open them in chrome and copy from them, then you can paste into ms word, and it keeps the formatting. But be sure to choose "keep source formatting".

You don't need to save these webpages you can just try copying the text below
תורה נביאים וכתובים

^^ try copy/pasting that into ms word, following the instructions in this post.

But these are examples of very simple webpages that work to demonstrate it too.

yaya.htm Note the meta tag with charset. Save this in notepad, as ASCII, that will save it as 1252 or as 8859-1(the only ascii notepad knows is iso 8859-1 or windows 1252, notepad doesn't know 1255). Chrome will read this in 1255(hebrew). And note the extra stuff in the HTML tag.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML DIR="RTL" LANG="HE">
<HEAD>
<META http-equiv="Content-Type" content="text/html; charset=Windows-1255">
</HEAD>
<BODY>
  <H1>úåøä</H1>
<H1>úåøä ðáéàéí åëúåáéí</H1>
</BODY>
</HTML>

yaya2.htm Save this in notepad as UTF-8 . Note the charset in the meta tag as UTF-8. Also the extra stuff in the HTML tag.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML DIR="RTL" LANG="HE">
<HEAD>
<meta http-equiv="content-type" content="text/html;charset=UTF-8">
</HEAD>
<BODY>
<H1>תורה נביאים וכתובים</H1>
</BODY>
</HTML>

When you open these webpages in Chrome,

Or forget the webpages, and when you just copy this: תורה נביאים וכתובים

Select text, select more than one word(as you want to make sure the words come in the correct order). And copy, then paste into ms word 2010.

You get this appear. i.e. just near the text you paste in, it says "ctrl", then click that and you can choose "keep source formatting" That should ensure the words are in the correct order.

Here is a pic from Ms Word 2010, giving the option you want, after you've selected from a webpage e.g. yaya.htm or yaya2.htm, and clicked copy, and you've chosen to paste it into ms word. note that "keep source formatting" option! That can put words into the correct order if they're in the wrong order.

keep source formatting

Third thing to do- Clicks of Heading1, clicking it two or three times.

And now for making it Header 1 and by clicking Header 1 multiple times.

If I choose two words from here http://www.mechon-mamre.org/b/h/h26.htm

they come out the wrong way around when I copy/paste them into word

Interestingly when I choose these three words תורה נביאים וכתובים from here http://www.mechon-mamre.org/i/t/t0.htm

They come out the correct way.

The answer is related to the Font being a Heading! That makes it work!

So, if we go to the webpage, look at two words there, how they should appear. Copy them to the clipboard http://www.mechon-mamre.org/b/h/h26.htm http://i.imgur.com/M9Ngo6J.png enter image description here

Paste it into ms word http://i.imgur.com/xg9JYYI.png enter image description here

Notice it comes up with the second words before the first word. So the two words are coming up in the wrong order (though letters are in the correct order).

Now select it and click "Heading 1" Notice it is still coming up the wrong way http://i.imgur.com/SsRxwsE.png enter image description here

But now highlight it or keep it highlighted and click Heading 1 again!! That fixes it http://i.imgur.com/o1Z7lRi.png enter image description here

Another example of how clicking Header 1 two or three times fixes it. In this case the letters were a bit mixed (the last letter of the last word seemed to join to the first word for some reason, though the words were in the right order, but clicking header 1 twice still fixed that!)

enter image description here enter image description here

share|improve this answer
    
Well done for finding that but I don't think it counts as a solution, the OP won't want to have all text as headings. Also, it seems to have changed the font. Seriously though, well found! –  terdon May 24 '13 at 14:18
    
@terdon the funny thing is that clicking "Heading 2" doesn't do the trick, only clicking Heading 1 does, and heading 2 would be a bit smaller than heading 1, though doesn't do it. Also, I found it requires another step besides clicking heading 1 multiple times - added to answer. –  barlop May 24 '13 at 20:57
    
@terdon added a new first step that removes the need for "Heading1" and fixes a problem of copy/pasting from other applications into ms word 2010, (by edit the hebrew into a webpage opened in chrome before copy/pasting! - template provided) and removes the need for the second and third steps! –  barlop May 25 '13 at 8:26
    
@terdon doh.. it's possible that <pre> works though I ran into one issue once when copying from within ms word. <h1> really seems to work. <h2> might but I haven't yet tried it as much as <h1>. (and there's no need to click Heading1 or Heading anything, when you're copying it and it's already a heading. <h2> of course being smaller, may be preferable. But another thing that seems to work is putting it as <h1> copy/pasting it into ms word, (choose "keep source formatting" of course) then you can remove the bold and decrease font size! –  barlop May 26 '13 at 9:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.