Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I do a "cd" at the Konsole, I get a warning msg

(echo: Command not found.

I think this happens because Konsole tries to output the path to the new directory, but instead of doing echo $cwd, I've done (echo $cwd. Now, I dont remember where I did this. Its not in my .cshrc, nor in my .cshrc_user file. Where else should I look for it? It'll also be fine if I can just turn off this feature, but how can I do that? Thanks

share|improve this question

migrated from stackoverflow.com Mar 7 '13 at 8:18

This question came from our site for professional and enthusiast programmers.

    
Maybe it's in .login? – Barmar Mar 7 '13 at 7:19
    
What's your shell? Does \cd work? Is this a Linux system or have you installed KDE on a Unix box? – terdon Mar 7 '13 at 11:54

Check to see what is in your PS1 variable.

You can try something like this in your home directory to find which file you modified it with:

grep PS1 .[a-zA-Z0-9]*

I personally like to use:

export PS1="\\\${PWD}
\`/usr/xpg4/bin/id -un\`@\`uname -n\`$ "

The location of the "id" executable might be different for you. Try this to find out where it is:

type id

You need one that takes the parameters "-un"

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .