Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Intel Atom D2500 processor which the spec site claims it supports a 64-bit instruction set. However, cpuinfo shows this:

# cat /proc/cpuinfo | egrep "(processor|flags|address)"
processor       : 0
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36  clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon pebs bts  nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl tm2 ssse3 xtpr pdcm movbe lahf_lm arat
address sizes   : 36 bits physical, 32 bits virtual
processor       : 1
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36  clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon pebs bts  nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl tm2 ssse3 xtpr pdcm movbe lahf_lm arat
address sizes   : 36 bits physical, 32 bits virtual

Does anyone know any way to enable the lm flag in the processor? So I can use a 64-bit kernel?

share|improve this question
1  
What motherboard to you have? –  Brad Patton Mar 7 '13 at 14:26

1 Answer 1

You can really easily test this with any Live 64bit Linux distro. I can confirm that Linux Mint 15 64bit runs on D2500, but has really bad GPU artefact issues.

share|improve this answer
    
Well, it looks like it will depend on the motherboard manufacturer, so my MB did not supported long mode, and that why it did not work. –  Vargas Nov 18 '13 at 11:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.