Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have asked this question on stack overflow but its probably better suited here.

So I have a Motorola MC3190 Mobile Barcode scanning device with Windows CE 6.0.

Now I want to get the device to sync its date/time on boot up with our domain controller using a registry file that I have created.

I have used this registry file below to get close to what I require.

REG 1

REGEDIT4

[HKEY_LOCAL_MACHINE\Services\TIMESVC]
"UserProcGroup"=dword:00000002
"Flags"=dword:00000010
"multicastperiod"=dword:36EE80
"threshold"=dword:5265C00
"recoveryrefresh"=dword:36EE80
"refresh"=dword:5265C00
"Context"=dword:0
"Autoupdate" = dword:1 
"server" = "NAMEOFMYSERVER" 
"ServerRole" = dword:0
"Trustlocalclock" = dword:0 
"Dll"="timesvc.dll"
"Keep"=dword:1
"Prefix"="NTP"
"Index"=dword:0

[HKEY_LOCAL_MACHINE\nls]
"DefaultLCID" = dword:00000809 
[HKEY_LOCAL_MACHINE\nls\overrides]
"LCID" = dword:00000809

[HKEY_LOCAL_MACHINE\Time]
@ = "UTC"
"TimeZoneInformation"=hex:\
      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00

[HKEY_LOCAL_MACHINE\Time Zones]
@ = "UTC"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Clock]
"AutoDST" = dword:00000000 

Now it gets the correct date and shows the time zone correctly however the time is always 5 hours behind on Eastern Standard Time, which is really annoying.

I have researched heavily into this and this question has been asked before here

As you will see I have copied what it suggests but it doesnt work.

Something is overiding the time which I dont understand enough about to resolve.

I cannot find any other setting to get it to set the time correctly.

Any help would be greatly appreciated.

share|improve this question
    
In future you should flag for a question to be migrated rather than posting duplicates. – Karan Mar 8 '13 at 18:48

Change the line to:

[HKEY_LOCAL_MACHINE\Time]
"TimeZoneInformation" = hex:\
      b4,00,00,00,45,00,2e,00,20,00,53,00,6f,00,75,00,74,00,68,00,20,00,41,00,6d,\
      00,65,00,72,00,69,00,63,00,61,00,20,00,53,00,74,00,61,00,6e,00,64,00,61,00,\
      72,00,64,00,20,00,54,00,69,00,6d,00,65,00,00,00,00,00,00,00,02,00,00,00,02,\
      00,02,00,00,00,00,00,00,00,00,00,00,00,45,00,2e,00,20,00,53,00,6f,00,75,00,\
      74,00,68,00,20,00,41,00,6d,00,65,00,72,00,69,00,63,00,61,00,20,00,44,00,61,\
      00,79,00,6c,00,69,00,67,00,68,00,74,00,20,00,54,00,69,00,6d,00,65,00,00,00,\
      00,00,00,00,0a,00,00,00,03,00,02,00,00,00,00,00,00,00,c4,ff,ff,ff
share|improve this answer
    
Please translate your answer to English, add proper formatting and explain what is it exactly that this registry modification does. – gronostaj Jun 28 '13 at 14:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .