Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a WRT54G2 router (V1) with the most recent firmware that serves as the gateway between my Internet connection and my home network. Over the past few months, I've noticed that the router seems to consistently become unusable due to high latency when it runs for any period of time. The internet connection is working, but the latency is sometimes as high as 2000ms to ping Google or to run a test from Speedtest.net. When a computer is directly plugged into the cable modem provided by my ISP, the problems resolve.

Restarting the router proivdes a resolution of the problem, but over time the latency issues increase again until it needs to be restarted. Right now, I have it on a mechanical (plug) timer that restarts it every morning around 4AM, but this still doesn't seem to fix the overall issue; I've had to restart the router manually twice today. Before restart, my ping will be over 1000ms; afterward, it will drop back to 20-60ms.

Note that the download and upload speeds don't seem to be affected by this, just the latency itself.

The problem appears on both wireless and wired connections.

I'm not sure if this is a sign that our router is failing (it was purchased in 2009, so as far as consumer-grade solutions go, it's lasted a pretty decent span), or if there's some misconfiguration on my end, or if something with my ISP is making my router flip out. What can/should I do to fix this issue (please note that flashing the router with DD-WRT is not an option, this version generally sees decreased performance when DD-WRT is installed).

EDITED TO ADD: I have ruled out internal traffic causing the problem (I reviewed the log files for the router and tried to identify any unknown stuff, but it seems fine). I can't quite figure out exactly what causes the router to develop the issue, but once it does, I've noticed the following:

  • Extremely high latency (1000ms+) for pings from any computer inside the network to an outside destination
  • The router itself cannot ping or traceroute once it has started developing these high latency issues - if you use the router's PING feature, it returns all timeouts.
  • It does not seem to correlate with any specific type of traffic.
share|improve this question
    
You should rule out traffic as the cause of the high ping. Rebooting the router may disconnect the application causing the traffic, leaving everything fine until it reconnects. –  David Schwartz Mar 7 '13 at 20:24
    
Are you referring to an internal application, i.e. something on my network? –  TARehman Mar 7 '13 at 20:33
    
Yes. Like one of your computers being part of a botnet. A clustering downloader like torrenting. That kind of thing. –  David Schwartz Mar 7 '13 at 20:34
1  
Your life will be a lot easier if you flash the router with DD-WRT. It's hard to debug a closed-source firmware, and a heck of a lot easier to debug one running an open-source, well documented OS, and DD-WRT is infact Linux-based. Just sayin'... It would also allow you to schedule hard reboots without having a physical cord reset the router (you can enable periodic/scheduled reboots in the administration menu). –  Breakthrough Mar 18 '13 at 18:09
1  
From my original post: "please note that flashing the router with DD-WRT is not an option, this version generally sees decreased performance when DD-WRT is installed" –  TARehman Mar 18 '13 at 18:11

1 Answer 1

up vote 1 down vote accepted
+100

I would suggest doing first a factory reset by pressing and holding the reset button of the router for straight 30 seconds while powering on.

If that helps, everything is fine. But if it doesn't, then the prognosis is less than optimal.

Other people in your situation have given the following advice.

From Resetting Router after Firmware Upgrade says (frankly it sounds like black magic, but some people claim it helps) :

I was told by Linksys Support that I should Reset my router after updating the Firmware. I had never heard of this before. They gave me the procedures below :

  1. Press and hold the reset button of the router for straight 30 seconds while powered on, and then unplug the power cord for 10 seconds and power up again.
  2. Connect a PC to the port 3 of the router then restart the PC. (This PC should be the one that can get online if directly connected to the modem). No connection yet to the modem, so only router and computer.
  3. Access the router's setup page then on that PC.
  4. To access the router's setup page, launch an Internet Explorer browser [or any browser you are using if you don't have IE]. On the address bar, please type 192.168.1.1 and then hit Enter/Return key. A log-in screen will appear.
  5. A log-in screen will appear. Please leave the username blank or empty and type admin for the password in lowercase and then hit OK.
  6. On the router's setup page, click on the MAC Address Clone sub tab and click on Clone your PC's MAC then save the settings.
  7. Click on the Wireless tab. Change the SSID from linksys to your family name or any name that never existed as a wireless network before to avoid network interference.
  8. Change the channel to 11 as well and make sure that your SSID Broadcast is enabled. Click on Save Settings.
  9. Click on the Security tab and disable or uncheck the 'Block Anonymous Internet Requests', then click on Save Settings.
  10. Go back to the Setup tab and look for the Local IP Address which is 192.168.1.1.
  11. Change the IP address to 192.168.2.1 then save the settings.
  12. Connect modem to Internet/WAN port of the router and shut down everything for 2 minutes.
  13. Power on. (Starting from the modem then the router and lastly your PC).

From Slow Wireless Connection (WRT54G2) (looks like this is oriented toward wireless, but may be worth trying) :

  • Open up the browser and on the address bar type 192.168.1.1 that will open up the Router setup page.
  • Lower the MTU (Maximum Transmission Unit) from 1500 to 1400 or less (usually found on your routers main/ basic setup page)
  • Then go to the Wireless tab, keep network mode as mixed, make the Channel Width to 20 MHz only and Channel to 6, 9, 11..
  • Adjust the following advanced wireless settings:
    • Lower the beacon interval from 100 to 75
    • Lower the fragmentation threshold from 2346 to 2306
    • Lower the RTS threshold from 2347 to 2304

If nothing helps, then you are not the only frustrated owner of the WRT54G2.

In case you would like to try DD-WRT anyway, this wikipedia article lists versions v1-1.3 of the router as compatible, but not v1.5. Here is the installation procedure.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.