Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently set up an Apache web server under ubuntu 12.10 and am having trouble when clients access it from the same network it's on.

Outside my wifi network, clients use "myurl.com". The host records on the URL are set up to point to my home router. A local static IP is used for the server. Port 80 is forwarded. Everything works perfectly.

The problem is when someone is connected to the same network the server is on, "myurl.com" doesn't work and brings them to the router login screen instead. Using the local IP (192.168.1.blah) works fine though, as if the user typed in "myurl.com".

Is this from improper configuration?

share|improve this question
add comment

1 Answer 1

The problem is how your router implements its IP stack. There is a very good video from DEFCON 18 which approaches this from an attacker's perspective, but the information is still relevant to your problem.

The gist of the situation is that your router tries to be helpful by accepting packets originating from the internal network which are destined to the router's public IP as if they were actually destined to the internal IP address. This causes the router to service the request with the admin server, instead of passing it along to the web server.

This weak/strong implementation isn't something you can change (without reflashing), so the likely solution will be to either switch routers or see if your router can restrict the admin site to certain origin IPs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.