Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run ubuntu server inside a virtual machine on my windows 7 (64 bit) laptop. I am a developer so I need to run server software on the ubuntu virtual machine. Ubuntu also needs to go out to the internet for git updates, etc.

As far as I can tell, I can't use NAT because I can't be able to host a server on ubuntu and have clients on my windows host connect to those servers.

I also don't believe I can have any sort of internal or host only network since the ubuntu virtual machine needs access to the internet for package managers, git, etc.

That leaves me with bridged network. I select bridged network on both, vmware player and virtual box, but I am not able to connect to the internet from ubuntu virtual machine. I AM able to connect to the net when networking is set to NAT (true for both, vmware player and virtualbox).

How the heck can I resolve this issue? What more information do I need to provide?

share|improve this question
    
Do you have a static IP address assigned in your VM that is set up for the NAT configuration? If the adapter is set to DHCP, Do you get an IP address from your DHCP server when in Bridged mode? Do you have a DHCP Server? –  Dave Lucre Mar 8 '13 at 1:51
    
@DaveLucre I have a wireless router which, i believe, serves as dhcp server. I haven't modified the VMs to change their dhcp settings. The only thing I changed was 'NAT' to 'Bridged' –  user14660 Mar 8 '13 at 2:00
2  
Out of the box, Ubuntu should be set up to get an IP from your DHCP server. If you're in Bridged mode, it should 'just work'. Do an ifconfig on the ubuntu box and find out what IP it has. It should be in the same range as your Windows 7 machine. i.e. if your 7 machine is 192.168.0.12, your Ubuntu box should be 192.168.0.X (where x is a different number). –  Dave Lucre Mar 8 '13 at 2:05
    
My windows ip is 192.168.42.1 and my linux ip is 192.168.2.23. Are they supposed to be only off by a digit or so? –  user14660 Mar 8 '13 at 5:53
    
Your windows machine's 192.168.42.1 adapter is the NAT adapter iirc. If your VM isn't in nat mode, this adapter is not in use. You should have another adapter in there, maybe called 'Local Area Connection' and that adapter is most likely the right one. If the IP address of THAT adapter is in the 192.168.2.* range then the address you have in your Linux VM is probably coming from the DHCP Server. Please check and report back. –  Dave Lucre Mar 10 '13 at 22:35

1 Answer 1

after the installation /etc/networks contains link-local 169.254.0.0. after the switch to a bridged network, there is ipv6 supported. maybe it is the same problem described at https://communities.vmware.com/message/2268606

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.