Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm wondering why my FTP server won't work. I host an Apache web server off of an old computer, and decided to make a parallel FTP server for uploading files to the website.

So I installed FileZilla (the server, not the client). I configured the user accounts, default directories, etc. I forwarded the ports, both 20 and 21, yet when I try to access it, it times out. If I'm on either LAN or WAN, I enter in the appropriate IP or dynamic address, and it prompts me for my password. I enter the correct password, FileZilla verifies it, and it attempts to retrieve the directory.

I have also allowed both ports 20 and 21 through the Firewall (ingoing, outgoing, TCP, UDP just to be sure).

After the time-out period (15 seconds or so) it errors out for that reason. I have tried this in Chrome, Firefox, Windows Explorer, and the FileZilla client. Every time, it times out, but only after connecting to the server and verifying my credentials.

I'm wondering what the issue is here. My ISP does not throttle any protocols or ports, be it HTTP, BitTorrent, or FTP. Is it just because of a slow upload speed? I have a 500 kB/s upload speed, so I don't think that's the problem. If there's anything I'm missing here, can someone please enlighten me? I've thoroughly scanned the internet and still can't find anyone else with this issue.

share|improve this question
add comment

1 Answer

This problem will most likely have to do with your NAT/firewall/router and the configuration of the FTP server.

FTP servers have 2 modes, Active and Passive. (You are probably using Active, and there is a reasonable chance shifting to Passive mode will work for you). Active Mode initiated a second connection FROM the server back to the client, and this is probably not being correctly translated by the router.

Have a look at http://slacksite.com/other/ftp.html for a fuller explanation.

(This probably doesn't help you, but if you are using a Linux based router there is special a connection tracking module you can use to overcome this problem - nf_conntrack_ftp and nf_nat_ftp" which are designed to work around these limits and "play nice" with firewalls as well)

share|improve this answer
    
Sorry that this sounds kind of stupid, but how do I change it from passive mode to active mode in Filezilla? I don't want to misconfigure my network or screw something else up. And is there a definitive way to determine whether you have a NAT router? I have a Linksys E4200v2. –  E-swizz Mar 8 '13 at 23:43
    
I've never used filezilla, but Google has a lot of results on this. The change would also be a relatively trivial one (just a single setting). Have a look at support.tigertech.net/filezilla-passive –  davidgo Mar 9 '13 at 1:27
    
I tried connecting with passive mode, but it still doesn't work. When working with Filezilla, it verifies the credentials, but then returns "425 Can't open data connection." followed by "Failed to retrieve directory listing." Could this be the NAT router issue you were suggesting earlier? As I mentioned in the previous comment, I have a Linksys E4200v2. Does that router restrict FTP protocols? And if so, how do I implement the code you gave earlier? –  E-swizz Mar 9 '13 at 6:02
    
Hmm, rereading the question, I may have misunderstood it slightly ? When you are on your home PC, are the server and client on the same subnet ? If they are, traffic is not going through the router, so you can focus on Filezilla setup. IE, see if you can get it working locally first, then sort out remote/firewall access if needed (And no, I don't have knowledge of an E4200v2 router specifically) –  davidgo Mar 9 '13 at 8:23
    
As I said earlier, it doesn't work on LAN. (I host the server in my house.) So yes, they are on the same subnet. Nor does it work on WAN, so I'm assuming the problem is with FileZilla. My previous post gives more information on the specific error I get when I try connecting with passive mode. –  E-swizz Mar 9 '13 at 23:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.