Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to install the JavaFX SDK and it keeps telling that it requires the current JDK to be installed, which I definitely have. Why doesn't the installation recognize my JDK? How can I fix this so I can install the JavaFX SDK?

share|improve this question
    
More information about the operating system being used is required to answer this question. –  Ramhound Mar 8 '13 at 12:03
    
Sorry for missing that. I'm working on Windows 7 Prof. x64 –  Florian Peschka Mar 8 '13 at 12:37

1 Answer 1

See settings in deployment.properties file

type "%APPDATA%\Sun\Java\Deployment\deployment.properties" | find /I "\\Java\\"

or

type "%APPDATA%\Sun\Java\Deployment\deployment.properties" | find /I ".path=" | find /I "deployment.javaws."

serach JVM JDK path:

type "%APPDATA%\Sun\Java\Deployment\deployment.properties" | find /I "jdk"

search JVM JDK cpl console x64:

dir /B /S %ProgramFiles%\Java\*javacpl.exe | find /I "jdk"

search JVM JDK cpl console x86:

dir /B /S %ProgramFiles(x86)%\Java\*javacpl.exe | find /I "jdk"

run JVM JDK cpl console:

C:\App64\Java\jdk1.7.0_02\jre\bin\javacpl.exe

jump to deployment.properties file

explorer "%APPDATA%\Sun\Java\Deployment"

see registry Java addon:

powershell gci 'hklm:\SOFTWARE\Classes\CLSID\{CAFEEFAC*'-rec^| gp ^| select '(default)', PSPath ^| ft -auto

del java and javaw at %windir% and %windir%\system32

del /Q /F %windir%\system32\java.exe
del /Q /F %windir%\java.exe

del /Q /F %windir%\system32\javaw.exe
del /Q /F %windir%\javaw.exe

The fact that it is a disgrace greatly hinders the developer when they have many JVM. Do not rely on the default path, if possible, do not use the system path, because may lie in the system32 java version 1.6 jre installed at 1.7, 1.6 jre and jdk. Create ways to run applications in the batch file and then run it. A similar problem with the environment variables Java: CLASSPATH, QTJAVA, JAVA_HOME, JRE_HOME, JDK_HOME; Use "%APPDATA%\Sun\Java\Deployment\deployment.properties".

see JRunner.cmd Eclipse Java Testing Tools - JAVA SE and JSP

Not use Java in environment PATH

save variable environment Java:

set | find /I "java" > c:\java-env.txt

save variable environment:

set > c:\set-env.txt

view variable environment Java:

set | find /I "java"

del variable environment Java:

setx CLASSPATH "" 
setx QTJAVA ""
setx JAVA_HOME ""
setx JRE_HOME ""
setx JDK_HOME ""

Change PATH variable, del Java directory path.

Before running JavaFX set environment variables in cmd and run install JavaFX.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.