Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello I am using Putty Pageant for using key authentification to remote server. On remote server to which I am connecting I have public key stored in authorized_keys file. Permissions and content of .ssh looks following:

SU-nemesis:/home/admin/wakatana/.ssh# cat authorized_keys
ssh-rsa AAAAB3NzaC1yc2EAAAABJQAAAIBSrXvWmCepiddDBqJuyBwImIqh5EAT3LwquweZ9B4BdtcdA5rWnplfVEAU4urIxzcvg2l/ODu5jK6r/DwBrPFqVhEDwu3WyCKNuxVSEJlZLw4TWqgcGORfXTCD03nruBo3TKyejZztUKv6UWA81BApTABQ8fdhH6UnCaYUnfwyoQ==
SU-nemesis:/home/admin/wakatana/.ssh# ls -la /home/admin/wakatana/.ssh
total 20
drwx------ 2 wakatana wgroup 4096 Feb 27 14:34 .
drwxr-xr-x 3 wakatana wgroup 4096 Feb 21 18:25 ..
-rw-r--r-- 1 wakatana wgroup  209 Jan 24 12:00 authorized_keys
-rw------- 1 wakatana wgroup  460 Feb 21 16:16 id_rsa
-rw-r--r-- 1 wakatana wgroup 4090 Feb 28 17:46 known_hosts

This si my public key which is loaded (with private) by Putty Pageant:

---- BEGIN SSH2 PUBLIC KEY ----
Comment: "rsa-key-20130124"
AAAAB3NzaC1yc2EAAAABJQAAAIBSrXvWmCepiddDBqJuyBwImIqh5EAT3LwquweZ
9B4BdtcdA5rWnplfVEAU4urIxzcvg2l/ODu5jK6r/DwBrPFqVhEDwu3WyCKNuxVS
EJlZLw4TWqgcGORfXTCD03nruBo3TKyejZztUKv6UWA81BApTABQ8fdhH6UnCaYU
nfwyoQ==
---- END SSH2 PUBLIC KEY ---- 

When I am logging via Putty (actually I am using PuTTY Connection Manager, but I think it is just wrapper of Putty) I see following message:

Authenticating with public key "rsa-key-20130124" from agent
Last login: Fri Mar  8 12:18:01 2013 from XXX.XXX.XXX.XXX

Yesterday I forgot to run Putty Pageant and connection to remote server still worked, no password asking just loging immediatelly! The message which I see is:

Authenticating with public key "rsa-key-20130124"
Last login: Fri Mar  8 12:24:37 2013 from XXX.XXX.XXX.XXX

How is this possible?

share|improve this question
up vote 2 down vote accepted

Have you told Putty to explicitly use a valid key in the Putty settings?

Connection -> SSH - > Auth -> Private key file for authentication

Pageant is good if you have multiple programs that need ssh connections.

share|improve this answer
    
Yes this the cause. I have found in registry under HKEY_CURRENT_USER\Software\SimonTatham\PuTTY\Sessions\SessionName\PublicKeyFile‌​ which points to my private key – Wakan Tanka Mar 27 '15 at 9:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .