Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Arch Linux (with Con Kolivas' ck1 patchset, although that shouldn't affect this issue) and using the proprietary Nvidia graphics driver, currently at version 313.26 (my card is a GeForce GTX 670).

I use redshift to adjust the color temperature of my screen for more comfortable/healthy viewing; it uses XRandR to do its thing. The problem is, it doesn't affect the cursor. So when I'm using my computer at night, the whole screen has a nice soft color, but the mouse cursor is rendered at the normal 6500K, which is really jarring. I can't provide a screenshot because the color adjustment only applies to the monitor.

The reason for the cursor ignoring the color change is that the cursor is rendered by the graphics hardware, and so it bypasses the processing that redshift applies. This is a known issue and the author of the program basically says he can't do anything about it.

I've tried enabling software cursor rendering using HWCursor off or SWCursor on (or both). This makes the cursor affected by the color adjustment, as expected, but the cursor is really glitchy. It lags, disappears every few seconds, and leaves strange artifacts wherever it goes. It's pretty much unusable.

On my laptop, using the open source Intel driver, the cursor is properly adjusted by redshift and it renders fine (no lag, artifacts, etc.). So that machine is either (a) using a software cursor which is working much better for some reason, or (b) using a hardware cursor which is properly applying the color adjustment. I don't know which it is, and I'm not sure how to find out (suggestions welcome).

So I need to either get the hardware cursor to obey redshift or get the software cursor to stop glitching. I'm thinking the latter would be easier, since I've seen many people with the former problem and haven't seen anyone with a solution. In any case, I'm not sure how to approach either problem and any help would be appreciated.

share|improve this question
    
Have you tried f.lux? –  gronostaj Mar 9 '13 at 9:12
1  
f.lux has the same problem. It's not anything about redshift that causes the problem, it's just that the hardware cursor bypasses pretty much any color adjustment. I've seen people have the same problem with f.lux on Windoze, even. –  qmega Mar 9 '13 at 13:55

1 Answer 1

Please convert this to a comment...

I use Redshift, the nvidia-331 driver and Ubuntu, on two monitors. Interestingly, the cursor only has this issue on one monitor. This is without any flags set for a "software cursor."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.