Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I usually install mysql, apache and php using the following commands

sudo apt-get install apache2 php5 libapache2-mod-php5 php5-mysql 

but after I did a fresh upgrade to Linux mint 14, I got these two errors

* Starting web server apache2                                                  
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Sun Mar 10 01:44:38 2013] [warn] NameVirtualHost *:8080 has no VirtualHosts
                                                                         [ OK ]
Setting up libapache2-mod-php5 (5.4.6-1ubuntu1.1) ...
 * Reloading web server config                                                  
 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Sun Mar 10 01:44:39 2013] [warn] NameVirtualHost *:8080 has no VirtualHosts
                                                                         [ OK ] 

I get the same error when i restart apache server as well. I haven't been able to make changes the directory of the localhost because of this.

share|improve this question
    
Those are only warnings and should not impact the performance of Apache. You won't see anything on the :8080 virtual host, but the default :80 should still be fine. What's your problem with the "directory of the localhost"? –  Oliver Salzburg Mar 9 '13 at 23:09
    
whenever i type localhost I get an error saying that the location does not exist. –  Bazinga777 Mar 10 '13 at 8:49
add comment

1 Answer

To fix that problem, you need edit your apache2.conf file (/etc/apache2/apache2.conf), and set ServerName.

Simply add the following line to the file:

ServerName localhost

Save the file and exit the editor. Don't forget to restart apache.

share|improve this answer
    
thanks, will give it a try –  Bazinga777 Mar 10 '13 at 8:27
    
I looked for the httpd.conf file in my apache2 directory and there was no httpd.conf file there. It's strange, can I paste some other httpd.conf from somewhere else to make it work ? Here are the contents of the directory apache2.conf envvars mods-available ports.conf sites-enabled conf.d magic mods-enabled sites-available –  Bazinga777 Mar 10 '13 at 8:47
    
@Bazinga777: OK, sorry, I didn't check which Linux you were running. Try this post for the possible location of the httpd.conf file. –  TFM Mar 10 '13 at 10:17
    
I tried it and i configured the localhost. Didn't work.I'm trying something else out right now. Will update the post if it works. –  Bazinga777 Mar 10 '13 at 19:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.