Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up SSH connection with a PC that is behind the DSL router.

I do know that to do that - I need to turn off firewall on the router and set up port forwarding.

So my firewall is off.

Forwarding is set up (according to this manual: http://qwest.centurylink.com/internethelp/modem-pk5000z-adv-port-forwarding.html

SSH to localhost works.

SSH through global IP doesn't work (just keeps connecting until I turn it off).

Is there anything else I need to do on ZyXel? I was setting up same thing on TP-Link router - and it took me two minutes.

share|improve this question

I had the same issue. I solved mine with nat rule from 2222 beginning port to 22 end port. Then I can succesfully connect to server with ssh user@global.ip -p 2222 command.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.