Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What version of bios does GA-Z77X-D3H rev 1.1 motherboard come with?

Since different minimum versions of BIOS are required for different CPUs as per their support list, but I cannot find what version of bios comes pre-loaded on the rev 1.1 motherboard.

(NB! I'm not interested in the rev 1.0, but if you have info for that one as well, listing it will be beneficial for completeness)

share|improve this question

closed as too localized by Karan, Ƭᴇcʜιᴇ007, terdon, Tog, Dave Mar 11 '13 at 9:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Totally not what you want, but some motherboards come with the ability to flash a motherboard without a working processor onboard through USB. Worth checking if your manual has that, then you can just install the latest. –  Journeyman Geek Mar 10 '13 at 0:44
    
From all the docs I read, one needs to be able to get into bios to ask it to load up / update from a file of a usb stick. And my problem is that I cannot get bios up. Plus the internets tell me that cpu is the one powering / processing of the bios update anyway. Catch 22. –  Dima Mar 10 '13 at 0:58
1  
@Dima - There is no way of us knowing this. Which revision of the BIOS would depend on which your specific motherboard was manufactured by Gigabyte. They flash the current BIOS revision which they package it. There are only two revisions you need to be concerned about F14 and F10. Which CPU are you trying to use exactly? –  Ramhound Mar 10 '13 at 8:22
    
@Dima - Have you even tried making a bootable USB device with the .exe file in question? –  Ramhound Mar 10 '13 at 8:29
    
@Ramhound yes, and the unpacked new image as well. Neither worked, no change. –  Dima Mar 10 '13 at 13:30

Browse other questions tagged or ask your own question.