Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to update PHP on a rackspace server, currently the server use PHP 2.6, i followed these instructions, i added to lines to /etc/apt/sources.list

deb http://php53.dotdeb.org stable all

deb-src http://php53.dotdeb.org stable all

the problem is in the 3rd step, i'm getting this:

Ign http://http.us.debian.org lenny Release.gpg
Ign http://http.us.debian.org lenny Release
Ign http://http.us.debian.org lenny/main Packages/DiffIndex
Ign http://http.us.debian.org lenny/contrib Packages/DiffIndex
Ign http://http.us.debian.org lenny/non-free Packages/DiffIndex
Ign http://http.us.debian.org lenny/main Sources/DiffIndex
Ign http://http.us.debian.org lenny/contrib Sources/DiffIndex
Ign http://http.us.debian.org lenny/non-free Sources/DiffIndex
Ign http://http.us.debian.org lenny/main Packages
Ign http://http.us.debian.org lenny/contrib Packages
Ign http://http.us.debian.org lenny/non-free Packages
Ign http://http.us.debian.org lenny/main Sources
Ign http://http.us.debian.org lenny/contrib Sources
Ign http://http.us.debian.org lenny/non-free Sources
Err http://http.us.debian.org lenny/main Packages
  404 Not Found [IP: 64.50.236.52 80]
Err http://http.us.debian.org lenny/contrib Packages
  404 Not Found [IP: 64.50.236.52 80]
Err http://http.us.debian.org lenny/non-free Packages
  404 Not Found [IP: 64.50.236.52 80]
Err http://http.us.debian.org lenny/main Sources
  404 Not Found [IP: 64.50.236.52 80]
Err http://http.us.debian.org lenny/contrib Sources
  404 Not Found [IP: 64.50.236.52 80]
Err http://http.us.debian.org lenny/non-free Sources
  404 Not Found [IP: 64.50.236.52 80]
Ign http://php53.dotdeb.org oldstable Release.gpg
Ign http://security.debian.org lenny/updates Release.gpg
Ign http://php53.dotdeb.org oldstable Release
Ign http://security.debian.org lenny/updates Release
Ign http://security.debian.org lenny/updates/main Packages/DiffIndex
Ign http://php53.dotdeb.org oldstable/all Packages
Ign http://security.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://security.debian.org lenny/updates/main Sources/DiffIndex
Ign http://security.debian.org lenny/updates/contrib Sources/DiffIndex
Ign http://security.debian.org lenny/updates/main Packages
Ign http://php53.dotdeb.org oldstable/all Sources
Ign http://security.debian.org lenny/updates/contrib Packages
Ign http://security.debian.org lenny/updates/main Sources
Ign http://security.debian.org lenny/updates/contrib Sources
Err http://php53.dotdeb.org oldstable/all Packages
  404 Not Found
Err http://security.debian.org lenny/updates/main Packages
  404 Not Found [IP: 149.20.20.6 80]
Err http://security.debian.org lenny/updates/contrib Packages
  404 Not Found [IP: 149.20.20.6 80]
Err http://security.debian.org lenny/updates/main Sources
  404 Not Found [IP: 149.20.20.6 80]
Err http://php53.dotdeb.org oldstable/all Sources
  404 Not Found
Err http://security.debian.org lenny/updates/contrib Sources
  404 Not Found [IP: 149.20.20.6 80]
W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/main/binary-amd64/Packages  404 Not Found [IP: 64.50.236.52 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/contrib/binary-amd64/Packages  404 Not Found [IP: 64.50.236.52 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/non-free/binary-amd64/Packages  404 Not Found [IP: 64.50.236.52 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/main/source/Sources  404 Not Found [IP: 64.50.236.52 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/contrib/source/Sources  404 Not Found [IP: 64.50.236.52 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/non-free/source/Sources  404 Not Found [IP: 64.50.236.52 80]

W: Failed to fetch http://php53.dotdeb.org/dists/oldstable/all/binary-amd64/Packages  404 Not Found

W: Failed to fetch http://security.debian.org/dists/lenny/updates/main/binary-amd64/Packages  404 Not Found [IP: 149.20.20.6 80]

W: Failed to fetch http://php53.dotdeb.org/dists/oldstable/all/source/Sources  404 Not Found

W: Failed to fetch http://security.debian.org/dists/lenny/updates/contrib/binary-amd64/Packages  404 Not Found [IP: 149.20.20.6 80]

W: Failed to fetch http://security.debian.org/dists/lenny/updates/main/source/Sources  404 Not Found [IP: 149.20.20.6 80]

W: Failed to fetch http://security.debian.org/dists/lenny/updates/contrib/source/Sources  404 Not Found [IP: 149.20.20.6 80]

E: Some index files failed to download, they have been ignored, or old ones used instead.
root@BOPS:~# apt-get update
Ign http://http.us.debian.org lenny Release.gpg
Ign http://http.us.debian.org lenny Release
Ign http://http.us.debian.org lenny/main Packages/DiffIndex
Ign http://http.us.debian.org lenny/contrib Packages/DiffIndex
Ign http://security.debian.org lenny/updates Release.gpg
Ign http://http.us.debian.org lenny/non-free Packages/DiffIndex
Ign http://http.us.debian.org lenny/main Sources/DiffIndex
Ign http://http.us.debian.org lenny/contrib Sources/DiffIndex
Ign http://http.us.debian.org lenny/non-free Sources/DiffIndex
Ign http://security.debian.org lenny/updates Release
Ign http://php53.dotdeb.org oldstable Release.gpg
Ign http://security.debian.org lenny/updates/main Packages/DiffIndex
Ign http://http.us.debian.org lenny/main Packages
Ign http://security.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://security.debian.org lenny/updates/main Sources/DiffIndex
Ign http://security.debian.org lenny/updates/contrib Sources/DiffIndex
Ign http://security.debian.org lenny/updates/main Packages
Ign http://http.us.debian.org lenny/contrib Packages
Ign http://http.us.debian.org lenny/non-free Packages
Ign http://http.us.debian.org lenny/main Sources
Ign http://http.us.debian.org lenny/contrib Sources
Ign http://security.debian.org lenny/updates/contrib Packages
Ign http://security.debian.org lenny/updates/main Sources
Ign http://security.debian.org lenny/updates/contrib Sources
Ign http://http.us.debian.org lenny/non-free Sources
Err http://security.debian.org lenny/updates/main Packages
  404 Not Found [IP: 128.101.240.212 80]
Err http://security.debian.org lenny/updates/contrib Packages
  404 Not Found [IP: 128.101.240.212 80]
Err http://security.debian.org lenny/updates/main Sources
  404 Not Found [IP: 128.101.240.212 80]
Err http://http.us.debian.org lenny/main Packages
  404 Not Found [IP: 64.50.233.100 80]
Err http://http.us.debian.org lenny/contrib Packages
  404 Not Found [IP: 64.50.233.100 80]
Err http://http.us.debian.org lenny/non-free Packages
  404 Not Found [IP: 64.50.233.100 80]
Err http://http.us.debian.org lenny/main Sources
  404 Not Found [IP: 64.50.233.100 80]
Ign http://php53.dotdeb.org oldstable Release
Err http://security.debian.org lenny/updates/contrib Sources
  404 Not Found [IP: 128.101.240.212 80]
Err http://http.us.debian.org lenny/contrib Sources
  404 Not Found [IP: 64.50.233.100 80]
Err http://http.us.debian.org lenny/non-free Sources
  404 Not Found [IP: 64.50.233.100 80]
Ign http://php53.dotdeb.org oldstable/all Packages
Ign http://php53.dotdeb.org oldstable/all Sources
Err http://php53.dotdeb.org oldstable/all Packages
  404 Not Found
Err http://php53.dotdeb.org oldstable/all Sources
  404 Not Found
W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/main/binary-amd64/Packages  404 Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://security.debian.org/dists/lenny/updates/main/binary-amd64/Packages  404 Not Found [IP: 128.101.240.212 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/contrib/binary-amd64/Packages  404 Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/non-free/binary-amd64/Packages  404 Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/main/source/Sources  404 Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/contrib/source/Sources  404 Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://security.debian.org/dists/lenny/updates/contrib/binary-amd64/Packages  404 Not Found [IP: 128.101.240.212 80]

W: Failed to fetch http://security.debian.org/dists/lenny/updates/main/source/Sources  404 Not Found [IP: 128.101.240.212 80]

W: Failed to fetch http://security.debian.org/dists/lenny/updates/contrib/source/Sources  404 Not Found [IP: 128.101.240.212 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/lenny/non-free/source/Sources  404 Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://php53.dotdeb.org/dists/oldstable/all/binary-amd64/Packages  404 Not Found

W: Failed to fetch http://php53.dotdeb.org/dists/oldstable/all/source/Sources  404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.    
share|improve this question

migrated from stackoverflow.com Mar 10 '13 at 3:32

This question came from our site for professional and enthusiast programmers.

1  
Well, /lenny doesn't exist on that server, so I would then assume that's your problem. Aside from that, as far as I can tell, this question is better suited for Super user. –  Daedalus Mar 10 '13 at 1:03
1  
php 2.6?? Just save it for the historical purposes. Really when was it installed? May be this is the only real instance of php 2.6 in the real world. If to take jokes apart, I would rather delete it and installed 5.3 from zero. I highly doubt that it supports such version jumps. –  Salvador Dali Mar 10 '13 at 1:16

1 Answer 1

up vote 1 down vote accepted

Your server is running a version of Debian Linux ("lenny", Debian 5.0) which has been unsupported since February 2012. Upgrade the server to a supported version of Debian (e.g, Debian 6.0, "squeeze") first.

share|improve this answer
    
i had to update to 6.0 and now everything works fine, thanks! –  Rommel Castro Mar 10 '13 at 7:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.