Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've written this on SuperUser as it's not a programming (programmers.se/stackoverflow) or Android-usage (android.se) question exactly.

The "Welcome to Android Development" wizard is a wizard which should pop up on first run of Eclipse after installing ADT Plugin. It allows you to select whether you want to send usage stats to Google. I don't mind one way or the other but it asks me every time I open Eclipse.

I'm on Linux Mint 14 (Nadia) x64. It's a new installation of Eclipse (Juno) from the Eclipse site, not from the software center. ADT is also on its latest version, freshly added using the update site from the Android dev page.

From the ADT changeset listed here it says:

...in particular it means the wizard won't be shown even if
you've wiped adtUsed=true from your ~/.android/ddms.cfg etc.

so I assumed that the true flag wasn't being correctly set in that file, but it is set. If I remove the file entirely, the popup still appears, and doesn't create a new one so perhaps it's entirely unrelated, but I'm not sure where else to look.

share|improve this question

It happened to me as well. I just had to completely erase the folder ~/.android as somehow I managed to create it with root privileges. So delete it with root privileges and restart eclipse so that is generated with your personal privileges.

share|improve this answer
    
step by step instruction would be better – Sickest Apr 18 '14 at 2:59
    
1) Close eclipse and open terminal (ctrl + shift + t) -- 2) cd ~ -- 3) sudo rm -rf .android -- 4) Reopen eclipse – martin Dec 26 '14 at 14:49

Well, this is just a guess, but it sounds like the program does not have the rights to read that config file. Perhaps it's running under different user creds or the permissions flags on the file/folder are not allowing it to read the flag from the file. Or maybe the program is looking in an entirely different folder for that file.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .