Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Back in the days of Gnome 2, I was happily using NX (NoMachine, FreeNX, neatx) for an extremely low-latency and usable connection to several Linux boxes. Everything worked like a dream.

Then, Gnome 3 came along, and it runs in fallback mode in NX. Keys started acting funny when I logged in, with down arrow becoming enter and lots of other strange stuff. I noticed that the keymaps were different from the NX session to the box I was connecting from, and after reading this post, I found that the following command (on any connect or resume) temporarily fixed the problem:

setxkbmap -model evdev -layout us

This is also confirmed on this bug report by NoMachine.

However, after my most recent upgrade to Gnome 3.6, this command doesn't fix things anymore. When I first start a session, keys do set of actions. If I run that command, they do a different set of actions, but still not the correct ones. There must be something distinctive about the way Gnome 3.6 is handling its keyboards versus Gnome 3.4/3.2, but I have no idea what it is. Perhaps some people can point out what changed with Gnome 3.6 so that I can use my system again.

Other posts about the issue, pre Gnome 3.6:

Before you flag this question as off-topic, please let me point out that NX is an extremely common tool for programmers, and Gnome 3 is the default display manager for many Linux distros. I feel that this question wouldn't get the right type of attention on AskUbuntu (I don't use Ubuntu) or SuperUser.

Updates:

share|improve this question

migrated from stackoverflow.com Mar 11 '13 at 2:42

This question came from our site for professional and enthusiast programmers.

http://anarsoul.blogspot.com/2012/10/gnome-36-and-keyboard-layout.html

From the above post, it seems that Gnome 3.6's gnome-settings-daemon seems to override xkbmap settings with its keyboard plugin, rendering any keyboard remappings useless. As suggested, it can be temporarily fixed by removing the keyboard plugin; on my system this is:

rm /usr/lib64/gnome-settings-daemon-3.0/libkeyboard.so

Then, the above setxkbmap command will work as normal in previous versions of Gnome 3.

However, this is clearly going to be a huge mess anyway with NX not directly working with evdev keyboard and the Gnome devs messing with the keyboard mappings. I just hope things converge at some point in the future.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .