Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a movie (m4v/h.264/AAC) which plays fine on my Mac but I recently discovered that it wont play on my Apple TV3. After looking at the properties of this movie file I see that it has a profile High@4.1 but Apple TV3's only suport up to High@4.0. I think the only property that is making this video incompatible is the max video bit rate, all of the other properties look like they are supported in High@4.0.

How can I use ffmpeg to downgrade this video to High@4.0?

Or do I have to instead change the actual property (max bit rate) that makes this video 4.1 instead of 4.0? I am worried that if I just change the bit rate, although the file would then be compatible with High@4.0 it would still be 'tagged' as High@4.1 and therefore still wouldn't play on my Apple TV3.

share|improve this question
add comment

1 Answer

When encoding with libx264, you can set the H.264 profile and level with:

  • -profile:v – one of high, main, or baseline (and others, but this is irrelevant here)
  • -level:v – as defined in Annex A of the H.264 standard, e.g., 4.0.

For example:

ffmpeg -i input.mp4 -c:v libx264 -profile:v high -level:v 4.0 -c:a copy output.mp4

Here we've just copied the audio stream since it won't be affected.

The output will have the correct profile and level set in its metadata. You can check this while encoding, where x264 says something like:

[libx264 @ 0x7fb26103a000] profile High, level 4.0

MediaInfo can also help you analyze container and codec details.

Of course, reencoding the video will degrade its quality to some extent, given that you're applying a lossy conversion again. Try setting the -crf option to influence the constant quality parameter. The default value here is 23, while values between 18 and 28 are considered sane. Lower means better quality. If your input has a bit rate of up to 65,000 kBit/s, chances are it'll still look pretty good after conversion though.

share|improve this answer
    
That worked well. Unfortunately it lost some of the metadata but the actual video didn't have any noticeable change in quality. Out of interest, would the following command have achieved the same thing? ffmpeg -i input.mp4 -vcodec x264 -vprofile high -vlevel 4.0 -acodec copy output.mp4 –  Sam Mar 13 '13 at 6:47
    
Yes, the -v options are aliases of the :v ones. What metadata did you lose? –  slhck Mar 13 '13 at 19:47
    
I think it might have just been the artwork that was lost. I don't know if that is technically considered metadata... Is the artwork actually contained within the file? I didn't check everything else before I added the whole to it again. –  Sam Mar 14 '13 at 6:10
    
I now have a different file with a similar problem. It is the wrong profile level but the rest of the specs seem to be compatible with my required level (4.0). If I use the commands you gave above, will it leave the data untouched unless it is incompatible with the entered profile level? Basically, I don't want ffmpeg to touch any of the data other than the tag that says what profile and level it is. Is that possible or is it going to set all of the values (nitrate, framerate etc) to preset values? –  Sam Jul 24 '13 at 10:38
    
If you use the above commands it will re-encode the video. If you wanted to just change the level information, you would have to modify the bitstream, which no program I know of can do, unless you write it yourself. The level is stored as raw bytes in the Sequence Parameter Set of the bitstream (you'd need to look up the ISO/IEC 14496-10 standard, sections 7.3.2.1 and Annex A for details). –  slhck Jul 25 '13 at 19:00
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.