Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Not sure this is the right place to ask this but here goes; last night, out of nowhere, my 3 year old Acer stopped working.

I can turn it on fine with or without the power cable plugged in, but after showing the Acer splash screen it just stops. I can press esc to see what's behind the Acer logo and it reads more or less (I'm writing on my phone):

Phoenix SecureCore...

V1.13
CPU = 1 Processors Detected... 
3768M System RAM Passed
256 kb L2 cache... 
... 
System BIOS shadowed
Video BIOS shadowed 

Press <F2> to enter SETUP

I left some stuff out but nothing looks like an error.

If I press F2 it says "Entering SETUP...." but nothing happens.

I've unscrewed the back to see if anything looked strange but the RAM seems fine.

Ideas?

share|improve this question

migrated from askubuntu.com Mar 11 '13 at 22:41

This question came from our site for Ubuntu users and developers.

    
What OS are you using? Is Ubuntu related with something? If it doesn't, this should be translated to SO. –  Lucio Mar 11 '13 at 22:25
    
I was using Ubuntu. But seems irrelevant as it never gets passed the first screen. Should I move it? Or does an admin do it? –  powerbuoy Mar 11 '13 at 22:35
    
Wait till a mod do that :) –  Lucio Mar 11 '13 at 22:39
    
So you get through POST and spash screen, can you get into BIOS? –  Carl B Mar 11 '13 at 22:51
1  
@powerbuoy - that may be another great question to post seperatly. You never know who has done what in SU with SSDs and info recovery. As a alternate question in here, especialy in the comments section, it will never be seen and may never get a good answer. –  Carl B Mar 12 '13 at 1:42

1 Answer 1

up vote 2 down vote accepted

I'd comment, but don't have the karma yet.

Pull the RAM out and put it back in. Try individual chips to be sure one isn't bad.

Try pulling the hard drive and putting it back in as well. See if you get farther without the HDD in (like a "can't find OS" type error.

Try booting a CD or perhaps a USB-key (a linux live distro is good for this).

Also, run some air through it, especially the CPU heat sink to make sure you don't have a heat/static issue from dust buildup.

After that -- quite possible the motherboard is indeed toast as Warren suggests. Can't get into BIOS is a very worrying sign.

share|improve this answer
    
Thank you for great tips. I was going to try the RAM one by one but seeing as it said "4gb RAM Passed" and I have 4gb in the box I figured that wasn't the problem. I tried switching to another HD and that worked though. What sucks is my old SSD seems toast and I had stuff on it I'd like to recover - any ideas on how to do that? I'll mark this as the correct answer even though I came on here to answer my own question (I switched HD before reading this). –  powerbuoy Mar 12 '13 at 0:07
1  
SSD? Ouch. The usual recommendation of SpinRite and Ontrack really are made more for traditional magnetic drives. Both will do aggressive read scans of an SSD, but I have no experience with that. SpinRite recovered a lot from a USB key for me, which is similar I suppose. A lot depends on the nature of the failure. Good luck, and backups, backups, backups. :) –  LilCodger Mar 12 '13 at 1:38
    
I've never had an hd failure block bios load. Weird. –  Warren P Mar 13 '13 at 1:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.