Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know this question has been asked several times, but I seem to have a special problem at hand. First, I will explain my setup and my needs. Second, I will try to give an overview of what I have tried so far.

Setup and Network

I have three computers (Win7, all) on my network, one of which is the computer (actually a media server) and the only one facing this issue. One computer and the media server are directly connected to a router (AVM Fritz!Box 7170 with newest firmware), the third computer is connected via PowerLAN<->router. I also have a RasPi directly connected to the router, and two mobile devices which are integrated via WLAN. I used to have my smartphone as the server's remote control (Unified Remote app), but switched to a new wireless mouse/keyboard for convenience during troubleshooting.

My Attempts

I asked several friends for advice after so many things have failed. First of all, the problem is definitely related to the NIC: I went to the Device Manager, turned "Device can turn on computer" off and the server never woke up on his own again. Good thing is: I know it's the NIC. Bad thing is: I want the NIC to wake up the server.

So I unplugged everything and turned on my network devices bit by bit:

  • Attached server to PowerLAN (at this stage, it still was connected to it)
  • Then turned on the router but w/o internet
  • Plugged in the internet
  • Turned on my computer with a fresh reboot and connected the computer to the router
  • Restarted the Raspberry Pi and connected it to the router

Then, the server went back on. I thought this couldn't be possible as it was a fresh install of Rasbian, unplugged it, powered the server down and it went back on immediately (we are talking of 1-10 secs). So I thought it might be a delay and my computer was responsible, turned that off too, powered the server down again, and it went back on. It then came to my mind that the PowerLAN might be responsible, so I unplugged the connection and put the server directly into the router, with positive result. I turned on all my devices, had the server running a few minutes, then put it down to sleep mode, had a walk, came back and it was still off. Retried, again successfully. So I figured the PowerLAN was responsible. I unplugged all cables, put the server back into the living room, started, put it to sleep mode, and it started again.

Out of despair, I blamed the smartphone remote that might send magic packets to keep it's connection alive, so I bought the wireless keyboard/mouse today. I had a look at powercfg -devicesomethingcommand wake_armed, saw that mouse and keyboard were able to wake the server, disabled that in the Device Manager, put the server to sleep mode, and it went back online immediately.

I've also had a look at the event manager but couldn't find anything suspicious, at least as far as I could tell. powercfg -lastwake returns no useful information, again as far as I can tell, something about an "activation device [0]".

The problem about google'ing the issue is that most people give the advice to disable the NIC's power-up ability, which I can't accept because that's what I want. Furthermore, I know that WOL works with magic packets as I've tested this with my self-written program sending the packet from my notebook (tested with server and computer, worked both times).

I shall be happy for any recommendations, hints, web sites. Please feel free to tell me what to do even if I have done it already and you feel like I did something wrong or should try more often (about network configuration, turning machines off and on again). Maybe we can find a solution together or find a pattern.

share|improve this question
    
Check you have any power saving options for the server nic disabled. I had a similar issue and that was the cause of it for me. –  GerryEgan Mar 18 '13 at 11:19
    
I did that, and the problem vanishes when I disable the NIC to wake the computer from any sleep mode, but this is what I intend to do - wake it up via magic packet from my RasPi. Following that, disabling the NIC's ability to boot after receiving a magic packet is not an option :-( –  Momro Mar 18 '13 at 15:14
    
There is usually an option in the NIC configuration (under Power Management) that says something like "Only allow a magic packet to wake the computer." Make sure this option is enabled. If not, you might need to see if there is an alternate device driver available. –  Harry Johnston Mar 19 '13 at 3:14
    
As stated above: ' I went to the Device Manager, turned "Device can turn on computer" off and the server never woke up on his own again. Good thing is: I know it's the NIC. Bad thing is: I want the NIC to wake up the server.' –  Momro Apr 18 '13 at 22:40
    
Is "only allow a magic packet to wake the computer" enabled? Have you tried using packet capture software to look for magic packets on the network? –  Harry Johnston Jun 17 '13 at 2:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.