Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I wish to retain the 'Open "safe" files after downloading' check box, as it contains things like images and pdf's that I do want to automatically open using Preview.

Although am sick of downloading MP3 files which are automatically added to iTunes and are immediately played back.

Anyway to stop this behaviour for JUST mp3's?

Thank you.

share|improve this question

Thats a good answer that Chris has - You can also change the default application using the OS.

Click get info on an .mp3 that you already have in your finder, there is a section "Open With", you may have to turn down the triangle.

If you change the app (to say QuickTime) or to another app that opens quickly, then click "Change All", your system will now by default use that application top open MP3 files.

That will at least get around the problem of them opening and importing in iTunes, and disrupting the currently playing music as well.

Hope that helps.

share|improve this answer

You might try changing the default application for .mp3 files.

  1. Download and install RCDefaultApp.
  2. In the Default Apps preference pane (now available in the System Preferences application), select the Extensions tab.
  3. From the list of extensions, select mp3.
    • scroll to and click on mp3, or
    • click on any extension in the list and then type “mp3”.
  4. For the Default Application popup menu, select <disable> (or some other application).

If you select <disabled>, you will be unable to automatically open .mp3 files in the normal ways (e.g. double-clicking on it in Finder), but you will still have the Open With submenu in Finder’s contextual menu for file items.

If you select some other application, it will automatically open .mp3 files when you download them with Safari, but you may prefer the on-open behavior of QuickTime Player (or some other application) to that of iTunes.

share|improve this answer

To disable it for all the files :

  1. Go to Safari preferences

  2. Disable the Open safe files after downloadingenter image description here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.