Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 RTM on a laptop and sometime between 7pm and 9:30pm tonight my sound stopped working.

I was away from the computer at the time and watched a youtube video with sound just before leaving, so I know the system was in working condition to start with before it went into sleep mode.

I've tried installing latest drivers, doing a system restore to last night's restore point, and rebooting multiple times. The headphone jack doesn't work either. There doesn't seem to be anything relevant in the event viewer either. The sound isn't muted (in either hardware or software) and really I'm just completely stumped. Far as the OS is concerned, sound should happen. Just nothing comes out of the speakers.

Anything else I can look into and test or are my speakers/sound card just dead?

EDIT: Apparently another reboot and a full shutdown was all it needed to start working again.

share|improve this question
    
Did you uninstall the old sound drivers before installing the new ones? Sometimes that makes a difference when just installing new drivers over the old ones doesn't. –  goldPseudo Oct 17 '09 at 4:03
add comment

2 Answers 2

up vote 1 down vote accepted

Don't know much about any issues particular with Windows 7, but you can test if it's a hardware problem rather easily by booting up into an alternate OS installation. Assuming you don't have a dual-boot system, this can also be accomplished with a linux live CD that supports your laptop.

I personally use Knoppix for such things (mostly just because I happen to have the CD handy) but there's myriad other options available. If sound works on one operating system, but not under the other, then it's pretty much a software problem. If sound doesn't work with either, it's probably a hardware failure.

share|improve this answer
add comment

I've had this to. I get a bit of static then nothing. Itunes won't even play a song.

To fix it tho you can go to the sound settings in the control pannel, go properties on your sounds device and under I think the advanced tab there is a test button. In the drop down list choose something different to what it is on, it will ask are you sure, say yes and the sound will work again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.