Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ubuntu is unable to connect to internet, both live CD and installed Ubuntu can't connect to network. The system sees the Ethernet interface from the look of ifconfig output:

*eth0
  Link encap:Ethernet  HWaddr 00:1d:04:4b:c4:bd  
  inet6 addr: fe80::23d:9ff:fe4b:c4bd/64 Scope:Link        
  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1  
  RX packets:302 errors:0 dropped:0 overruns:0 frame:0   
  TX packets:343 errors:0 dropped:0 overruns:0 carrier:0      
  collisions:0 txqueuelen:1000        
  RX bytes:20208 (20.2 KB)  TX bytes:74524 (74.5 KB)         
  Interrupt:16

lo
  Link enc ap:Local Loopback      
  inet addr:127.0.0.1  Mask:255.0.0.0        
  inet6 addr: ::1/128 Scope:Host         
  UP LOOPBACK RUNNING  MTU:16436  Metric:1         
  RX packets:756 errors:0 dropped:0 overruns:0 frame:0        
  TX packets:756 errors:0 dropped:0 overruns:0 carrier:0         
  collisions:0 txqueuelen:0        
  RX bytes:87621 (87.6 KB)  TX bytes:87621 (87.6 KB)*

dhclient eth0: 

*RTNETLINK answer: Operation not permitted*
share|improve this question

1 Answer 1

The problem would appear to be your computer does not have an IP address, and you are trying to invoke the dhclient to get it - but you are not root. You need to be root to attain a DHCP lease (try sudo dhclient eth0)

share|improve this answer
    
sudo dhclient eth0: [1]2591 but no connection –  user83171 Mar 12 '13 at 6:45
    
What happens if you try and bring the link up with a static IP, for example using the commands ifconfig eth0 X.X.X.X; route add default gw X.X.X.Y –  davidgo Mar 12 '13 at 6:56
    
i configured static IP and get ping working, but browser can't find pages claiming DNS lookup failed. –  user83171 Mar 12 '13 at 7:17
    
ok its working, thanks for help –  user83171 Mar 12 '13 at 7:23
    
Does DHCP work for other machines ? It sounds to me like your DHCP server is not handing out DHCP leases. The problem you have with the static IP address can be rectified by editing /etc/resolv.conf and adding a line "nameserver X.X.X.X" - of-course, the point of setting it up statically was to eliminate potential problems - we now know that your ethernet interface is working and connected to the Internet :> –  davidgo Mar 12 '13 at 7:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.