Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

By default, in Windows 7 start menu the item "Documents" opens a library containing current user's documents folder and public documents. I'd like to change that behavior to open current user's documents folder. How do I do that?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

You can change the Documents, Music, Pictures, Recorded TV and Videos links on the Start Menu to point to the user-specific directories (such as C:\Users\UserName\Documents) quite easily using the .REG files available here.

Check out the link for the other REG files, but for Documents specifically the following will do the trick:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{7b0db17d-9cd2-4a93-9733-46cc89022e7c}]
"ParsingName"="::{59031a47-3f72-44a7-89c5-5595fe6b30ee}\\{FDD39AD0-238F-46AF-ADB4-6C85480369C7}"

This will revert back to the default Documents Library:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{7b0db17d-9cd2-4a93-9733-46cc89022e7c}]
"ParsingName"="::{031E4825-7B94-4dc3-B131-E946B44C8DD5}\\{7b0db17d-9cd2-4a93-9733-46cc89022e7c}"

Note: A logout or restart might be required for the change to take effect.

share|improve this answer
    
It worked! Thanks a ton! –  user1306322 Mar 13 '13 at 1:12

Go to the Properties of "Documents" by right clicking it and remove all folders path in it , then click on "Include folder" and choose the new path that you want (Current's user documents folder) in your case.

share|improve this answer
    
This will change the folders included in Documents Library, but what I want is to remove the library and make that button in start menu a direct link to my Documents folder. –  user1306322 Mar 12 '13 at 8:46

You don't have to restart or re-log to apply. After changing the registry,

  1. Open Task Manager (Ctrl+Shift+Escape),
  2. Hit the second tab, "Processes",
  3. Hit 'e' - this should select "explorer.exe",
  4. Right click it, hit 'End Process' (or use the button at the bottom). Your screen should flash briefly and your desktop icons/taskbar will vanish.
  5. Go to 'File', at Task Manager's top left, hit "New Task (Run...)",
  6. Type "explorer.exe", exactly like in the process list.

This should all take less than a minute. When I opened My Documents, the icons were crammed in the left of the window. Changing icon size/view (ctrl+scroll) fixed it.

I do this when my dual monitor mod-apps bug. I've had apps crash - mainly Chrome, if I recall - but rarely.

share|improve this answer
    
Please read the question again carefully. Your answer does not answer the original question. –  DavidPostill yesterday
    
I am aware... The original question was already summarily answered, I was adding some input that I thought could be a useful supplement to the solution earlier provided. Apologies, I'm new here; should I have posted as a reply to Karan's answer? I had a poke around, and I found some guidelines for posting. One of the things mentioned is contributing to existing threads. I don't see how my post deserves a down-vote. –  RedShift yesterday

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.