Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I get the following error when run: It is somehow missing the perl dependencies, I am not sure do I need to update the perl or remove something as a workaround!

yum install git

Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.
--> Running transaction check
---> Package git.i386 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl-Git = 1.7.11.3-1.el5.rf for package: git
--> Processing Dependency: perl(DBI) for package: git
--> Processing Dependency: perl(Git) for package: git
--> Running transaction check
---> Package git.i386 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl(DBI) for package: git
---> Package perl-Git.i386 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl(SVN::Ra) for package: perl-Git
--> Processing Dependency: perl(SVN::Delta) for package: perl-Git
--> Processing Dependency: perl(SVN::Client) for package: perl-Git
--> Processing Dependency: perl(YAML::Any) for package: perl-Git
--> Processing Dependency: perl(SVN::Core) for package: perl-Git
--> Running transaction check
---> Package git.i386 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl(DBI) for package: git
---> Package perl-Git.i386 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl(SVN::Ra) for package: perl-Git
--> Processing Dependency: perl(SVN::Delta) for package: perl-Git
--> Processing Dependency: perl(SVN::Client) for package: perl-Git
--> Processing Dependency: perl(SVN::Core) for package: perl-Git
---> Package perl-YAML.noarch 0:0.72-1.el5.rf set to be updated
--> Finished Dependency Resolution
perl-Git-1.7.11.3-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: perl(SVN::Ra) is needed by package perl-Git-1.7.11.3-1.el5.rf.i386 (rpmforge)
git-1.7.11.3-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: perl(DBI) is needed by package git-1.7.11.3-1.el5.rf.i386 (rpmforge)
perl-Git-1.7.11.3-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: perl(SVN::Core) is needed by package perl-Git-1.7.11.3-1.el5.rf.i386 (rpmforge)
perl-Git-1.7.11.3-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: perl(SVN::Client) is needed by package perl-Git-1.7.11.3-1.el5.rf.i386 (rpmforge)
perl-Git-1.7.11.3-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: perl(SVN::Delta) is needed by package perl-Git-1.7.11.3-1.el5.rf.i386 (rpmforge)
git-1.7.11.3-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: perl(DBI) is needed by package git-1.7.11.3-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: perl(SVN::Core) is needed by package perl-Git-1.7.11.3-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: perl(SVN::Ra) is needed by package perl-Git-1.7.11.3-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: perl(SVN::Client) is needed by package perl-Git-1.7.11.3-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: perl(SVN::Delta) is needed by package perl-Git-1.7.11.3-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: perl(DBI) is needed by package git-1.7.11.3-1.el5.rf.i386 (rpmforge)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Can you please help me solve the issue? Thanks,

share|improve this question

migrated from stackoverflow.com Mar 12 '13 at 9:53

This question came from our site for professional and enthusiast programmers.

    
Did you tried what the error message suggested? running yum-complete-transaction –  fmendez Mar 7 '13 at 23:10
    
yeah no help does not help! –  ComeRun Mar 7 '13 at 23:13
    
yum-complete-transaction: command not found –  ComeRun Mar 7 '13 at 23:16
    
ok check my answer and let me know if that is of any help. –  fmendez Mar 7 '13 at 23:16
    
Are you sure git isn't available as an official package for RHEL? I'd be very surprised if so. Third party repositories might trample on the system packages, and get you into a situation from which it is hard to recover. –  vonbrand Mar 9 '13 at 19:07

3 Answers 3

Try adding this repo:

 http://pkgs.repoforge.org/perl-YAML/perl-YAML-0.72-1.el5.rf.noarch.rpm

and then run yum install git again.

EDIT

Try running yum install perl-DBI if you don't get an error then try running yum install git again. If you do get an error then you might want to try installing using RPM instead of yum, for instance:

wget http://packages.sw.be/git/perl-Git-1.7.3.4-1.el5.rf.i386.rpm
wget http://download.fedora.redhat.com/pub/epel/5/i386/perl-Error-0.17010-1.el5.noarch.rpm
wget http://packages.sw.be/git/git-1.7.3.4-1.el5.rf.i386.rpm

Then

rpm -i perl-Git-1.7.3.4-1.el5.rf.i386.rpm perl-Error-0.17010-1.el5.noarch.rpm git-1.7.3.4-1.el5.rf.i386.rpm
share|improve this answer
    
Cau u pls let me know how to add it to repo –  ComeRun Mar 7 '13 at 23:18
    
Try: rpm -Uhv http://pkgs.repoforge.org/perl-YAML/perl-YAML-0.72-1.el5.rf.noarch.rpm –  fmendez Mar 7 '13 at 23:20
    
prompts me with this: error: open of pkgs.repoforge.org/perl-YAML/perl-YAML-0.72-1.el5.rf.noarch.rpm failed: No such file or directory –  ComeRun Mar 7 '13 at 23:22
    
sorry try again with the http:// part on front, check my edited comment above. –  fmendez Mar 7 '13 at 23:23
    
now gives me this: Retrieving pkgs.repoforge.org/perl-YAML/perl-YAML-0.72-1.el5.rf.noarch.rpm error: skipping pkgs.repoforge.org/perl-YAML/perl-YAML-0.72-1.el5.rf.noarch.rpm - transfer failed - Unknown or unexpected error –  ComeRun Mar 7 '13 at 23:24

When you want to use yum on a Red Hat/Oracle Linux server which says "This system is not registered with RHN.", there is a wonderful option to add the free yum repository.

Read about licensing and Red Hat/Oracle Linux here: http://flashdba.com/2012/10/08/this-system-is-not-registered-with-uln-rhn/

Read how to add the Public Yum Server here: http://public-yum.oracle.com/

share|improve this answer
Error: Package: git-1.7.11.3-1.el5.rf.i386 (rpmforge)
           Requires: libcurl.so.3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Help meeeeee

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.