Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 2008 DC with a logon script in the default policy. This script has been tested and works if executed manually for admins and users.

However, when I login with an administrator it doesn't get executed. But it works fine for normal users.

The policy is supposed to be applied to all authenticated domain users. Is there a limitation for admin users or am I doing something wrong?

DC is Windows 2008, Clients are all Win 7

Update:

I have found the reason for this phenomenon,but unfortunately no satisfying solution.

First of all, if a user belongs to the domain admin group and UAC is enabled the logon script will not run in the user context but the admin context instead. So, the mapping is successfully happening, but for a different context, this is the reason for this odd behavior.

I have found some workarounds for this issue, but none of them really worked for me, which is why I simply have accepted that if you want to map network shares under Win7 make sure you aren't local or domain admin.

This issue is well known to Microsoft.

Source: http://pcloadletter.co.uk/2010/05/15/missing-network-drives/

Update 2:

There is a much more comfortable way to avoid the logon script and using Group Policy settings instead.

Go to User Configuration -> Preferences -> Windows Settings -> Drive Maps and do all the work here. This seems to solve the issue with administrator users and UAC and works just fine for me.

See http://blogs.technet.com/b/askds/archive/2009/01/07/using-group-policy-preferences-to-map-drives-based-on-group-membership.aspx for more details

share|improve this question
    
Have you checked the security permissions to be sure Apply Policy isn't denied to admins? –  LilCodger Mar 12 '13 at 18:44
    
I have added the admins even explicitly, still no change –  Dr.Elch Mar 14 '13 at 14:57
    
Have you done a Group Policy Results Wizard? Does it show as applied? Does it show an error? –  LilCodger Mar 18 '13 at 18:59
    
Yes everything works fine. See the update to my post for details –  Dr.Elch Mar 20 '13 at 14:56
1  
If all you're doing is mapping drives, yes -- that preference is the way to go. If you're looking to actually run a script, the workaround I use is User->Preferences->Files->File, and plant your script in the Start Menu startup folder. Guess I should have asked what you were doing with the script... . –  LilCodger Mar 21 '13 at 15:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.