Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am quite new to aircrack-ng, and learning it. But i got stuck on the airmon.

Please help me out here. Thanks in advance.

Details about system:

Operating System: Windows 8
Wireless: Dell Wireless 1704 802.11 b/g/n (2.4Ghz)

I have tried following but still not able to start the wireless card in monitor mode:

sudo airmon-ng 


Interface   Chipset     Driver

eth0        Unknown     wl - [phy0]

and sudo airmon-ng returns

Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
5694    avahi-daemon
5695    avahi-daemon
5743    NetworkManager
5818    wpa_supplicant
6951    dhclient
Process with PID 6951 (dhclient) is running on interface eth0


Interface   Chipset     Driver

eth0        Unknown     wl - [phy0]mon0: ERROR while getting interface flags: No such device

                (monitor mode enabled on mon0)

lspci | grep Network

02:00.0 Network controller: Broadcom Corporation Device 4365 (rev 01)

I tried killing all the process using airmon-ng check kill but they again get restarted, I think this is because networking is automatically started in ubuntu.

Please help. Thanks

share|improve this question

migrated from security.stackexchange.com Mar 12 '13 at 22:26

This question came from our site for Information security professionals.

6  
First Google result for 'airodump-ng', second paragraph, first sentence = Aircrack-ng -> Airmon-ng -> Airodump-ng -> Usage: "Before running airodump-ng, you may start the airmon-ng script to list the detected wireless interfaces." –  Noordung Mar 12 '13 at 21:56
    
Thanks Tidalwave. Next time onwards I will check these things before posting. Anyways I got stuck at this place and I am not able to start the interface in monitor mode. –  codeomnitrix Mar 19 '13 at 17:09
    
If it still doesn't work, kill those processes, last time I used it it was in fact necessary to kill the listed processes. –  Alex Mar 19 '13 at 17:30
    
But alex, I killed all those processes using kill processid but the again restarted automatically –  codeomnitrix Mar 20 '13 at 6:52
    
Try stopping or ending them then. If you have GUI Applications > System Tools > System Monitor. –  Alex Mar 21 '13 at 10:25

1 Answer 1

Already answered by codeo, but in details:

Before using airodump-ng, you have to start a virtual interface:

airmon-ng start your_physical_wifi_int

Then ifconfig -a should show something like mon0.

and at last airodump-ng mon0 should show your neighbour Wi-Fi AP and clients.

share|improve this answer
    
HI Card could you please help me, I have edited the question. –  codeomnitrix Mar 20 '13 at 9:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.