Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed the Opera browser on my Windows 7 64-bit.

since it is my main browser, I pinned it to the taskbar. however the opera icon does not appear, instead the default Windows icon is show. I even tried changing the icon to another one and unpinning and repinning, but still that default Windows file icon remains.

what could I do to show the icon?

share|improve this question
2  
Is it only Opera? Do you have same problem with other app icons? –  o.k.w Oct 17 '09 at 8:46
    
for the moment it is only opera. other applications work fine! –  clamp Oct 17 '09 at 8:52

4 Answers 4

up vote 3 down vote accepted

I had this problem with a CCleaner icon. It would be pinned, but be the blank unknown application icon. I just removed it and tried again. Worked second time. Don't know why!

share|improve this answer
    
thanks good idea! however it didnt help in my situation! –  clamp Oct 17 '09 at 9:29
    
It's possible that I had updated CCleaner before the second attempt. Have you tried updating or uninstalling and reinstalling Opera? –  outsideblasts Oct 17 '09 at 10:10
    
thanks! not yet, i will try soon! –  clamp Oct 17 '09 at 14:37
    
reinstalling helped. –  clamp Oct 17 '09 at 21:49

You may have to Rebuild the Icon Cache in Windows 7

Information

If one or more of your icons are not displaying correctly, or that your icon cache is corrupted, then you might consider rebuilding the icon cache to reset and reload the icon images into the icon cache.

Note
This will not help with any of the following icon issues:

1-A shortcut's icon that is not displayed properly due to the source
of the shortcut being moved or deleted. You may need to recreate a new shortcut directly from the source (ex: program's exe) file to replace it instead.
2- All icons for a specific file extension display the wrong icon. This may be do to setting the wrong association for what program to open the file extension instead. You can restore the default file extension's associations to fix this icon instead.

If you have check that the source icon is not corrupted use this solution:
Windows 7 - Icon Cache - Rebuild from the SevenForum tutorials

share|improve this answer

There is a solution posted at a Microsoft forum:

  1. First phase

    1. Click Start
    2. Right-click on Programs in the Start menu
    3. Select Properties ⇨ Shortcut tab ⇨ Change Icon ⇨ Browse
    4. Navigate to the .exe file for this program and select it
    5. Select an appropriate icon from options shown (if you get a message saying only an administrator can do this, click continue to apply the change.)

  2. Second phase

    1. Start a session of the application
    2. While it is running, right-click the taskbar button
    3. Select Unpin this program
    4. Right-click again (shows icon now because it represents the running app, not the shortcut)
    5. Select Pin this program
share|improve this answer

My problem was solved by setting my 'Taskbar buttons' taskbar setting to anything but 'Always combine, hide labels' (the default)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.