Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been trying to use yum now, but for some reason, not even the search work anymore. I even tried putting packages I already downloaded in the search criteria and is the same.

[root@AMDFX03 Downloads]# yum search glibc
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
epel/metalink                                            |  22 kB     00:00     
 * base: centos.secrel.com.br
 * epel: archive.linux.duke.edu
 * extras: centos.secrel.com.br
 * rpmforge: apt.sw.be
 * updates: centos.secrel.com.br
adobe-linux-x86_64/primary                               | 1.2 kB     00:00     
http://linuxdownload.adobe.com/linux/x86_64/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from adobe-linux-x86_64:
[Errno 256] No more  mirrors to try.

This error always appear no matter what I do. Please, can you tell me how to fix this, or at least how to reset yum's configuration?

share|improve this question

migrated from stackoverflow.com Mar 13 '13 at 5:15

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 2 down vote accepted

First of all, thanks to SnakeDoc for the help, I was feeling hopeless with this error. Second, I found in a forum that by adding http_caching=none to the yum.conf file in /etc/, I managed to fix the problem.

Seems that with "yum clean all" was cleaning, but was retrieving the corrupted metadata from the cache. With this, it'll be okay.

share|improve this answer
1  
i encountered the same problem with Fedora 18, i just temporarily disabled the adobe repository (yum --disablerepo adobe* or edit it's repository file in /etc/yum.repo.d), and then everything will be working again. –  LiuYan 刘研 Mar 14 '13 at 16:22

what centos are you on? 4.9 was EOL i think a bit ago and caused a similar issue to one of our servers.

sudo uname -a
sudo cat /etc/redhat-release

Paste the output of both cmds please.

it sounds like the GPG keys are out of date or invalid.

rpm --import http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5

or

rpm --import http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6

You should also try:

sudo yum clean metadata
sudo yum clean all
share|improve this answer
    
I'm on CentOS 6.3, by the way. –  Xanathos Mar 13 '13 at 6:06
    
sudo yum clean all might be the trick... i think either your keys are busted or yum database/cache is busted –  SnakeDoc Mar 13 '13 at 6:10
    
I tried from the url and also from a file in which I save the contents of the key for CentOS 6. It says: "curl: (7) couldn't connect to host error: mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6: import read failed(2)." –  Xanathos Mar 13 '13 at 14:35
    
OK, i managed to download the key, but it's the same result. The same error appears. I also put the "clean all" command from yum. u__u –  Xanathos Mar 13 '13 at 14:46
1  
I found the answer. I added http_caching=none to the yum.conf file. Seems the cache was kind of tampered and that's why was reloading corrupted metadata everytime. –  Xanathos Mar 13 '13 at 17:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.