Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My numpad works in iterm2 (bash), but it inserts characters instead of numbers in insert mode for vim.

How can I get vim to recognise the correct escape codes.

I have tried editing the escape codes as suggested here without any luck: http://code.google.com/p/iterm2/issues/detail?id=702

share|improve this question
up vote 78 down vote accepted

Looks like the answer is to go into Preferences->Profiles->Keys and load preset of: xterm with numeric keypad.

share|improve this answer
1  
I didn't have this preset, so in my answer I explained how you can add these shortcuts yourself. – rednaw Jul 13 '15 at 9:05
    
It appears that the preset no longer exists in iTerm 2.1.1 – scarver2 Aug 14 '15 at 17:28
1  
Recently did a new OS install. The preset is still there in iTerm 2.1.1. – J0hnG4lt Oct 2 '15 at 16:10
1  
Works in iTerm 2.1.4 too, though I also had to add a new shortcut to insert hex key code 0xd for NumPad's Enter key to work. (Weirdly not detected as the Num-⏎ key already registered, but as ⏎ on its own, when set up.) – ecmanaut Feb 23 at 19:34
    
Works for me. I'm using iTerm2 Build 2.1.4. – user3684424 Apr 20 at 15:48

For me the solution was disabling VT100 Application Keypad-Mode in Preferences > Profiles > Advanced.

share|improve this answer
2  
This solution works only on the native terminal, but not with iTerm – sic2 Dec 16 '15 at 9:36

You can add global keyboard shortcuts in Preferences -> Keys and map the numpad characters to "Send Text" actions to send the text they are supposed to send.

iTerm2 keys preferences

share|improve this answer
6  
For the Enter key, choose the Send Hex Codes action and enter 0x0D. – scarver2 Aug 14 '15 at 17:34

but it removes some colors in my vim.

if you just need it some times, just type:

:set term=ansi

in VIM

Best regards

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.