Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My office is a Windows environment, but I have just set up a linux (lubuntu 12.10) machine for me to develop on since I cannot access the command line in Windows.

I have set up the LAMP stack on the machine (which I've done numerous times before without fail), but I cannot access localhost, I get a connection refused error.

In order to use the internet on the machine I've had to add our proxy details to /etc/environment - the internet works fine.

If I get rid of the proxy settings, I can then access localhost, but that of course means I cannot get on the internet.

So how do I access localhost with a proxy enabled?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

I've not tried it, but a quick google suggests that you can set

no_proxy='127.0.0.1,localhost'
share|improve this answer
    
Thanks, I just solved this myself and was about to post an answer - you beat me to it. –  Robin Mar 13 '13 at 12:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.