Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to setup virtual host in Fedora18.

Configuration is following:

  • httpd version is 2.4
  • user/group - apache/apache
  • global document root is /var/www/html
  • vhost symlink: /var/www/html/vhost/domain.name -> /project/www.
  • all directories from / to /project/www have +x permission

When I start httpd manually (sudo httpd -k start) everything works fine. ps aux output for this case:

apache 23827 0.0 0.0 531040 7184 ? S 17:16 0:00 httpd -k start

But once i switch to systemctl (sudo systemctl start httpd) subdomain returns 403 error (Symbolic link not allowed or link target not accessible). ps aux:

apache 23556 0.0 0.0 428700 7676 ? S 17:00 0:00 /usr/sbin/httpd -DFOREGROUND

So I assume the difference is in -D flag but cannot find any useful info.

share|improve this question
    
It seems that -DFOREGROUND does not matter for current case. After manual start with sudo httpd -DFOREGROUND vhost works just fine. The problem appears only when using systemctl (systemd). –  Andrey Kucherenko Mar 13 '13 at 15:58
add comment

1 Answer

up vote 1 down vote accepted

Finally found the solution. SELinux blocks some permissions of httpd process. This and this were helpful.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.