Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu 12.10, my Gedit suddenly stopped showing files on the file browser. It only shows folders. I can open any file on Gedit, but the file browser doesn't show the files on the current folder.

If I open Gedit through terminal: sudo gedit Then, I see the files, so I think this is an issue related to user permissions.

I tried reinstalling the application from Ubuntu software center and also by doing: sudo apt-get install gedit.

However, I still have the same problem: Starting Gedit from the Dash doesn't show any files.

Also, I tried this solution (Why won't gedit file browser plugin show files?), but it didn't work.

A screenshot: (Gedit shows 'empty', but there are several files inside the folder)

enter image description here

Any advice?

share|improve this question
    
Could you post a screenshot of the browse window? –  washbow Mar 14 '13 at 2:02

1 Answer 1

I finally found the problem!! Actually it is a very dumb thing. I'll leave this answer for further reference:

If you leave a blank space on the file browser's match input box and then close Gedit. The next time you open Gedit, the file browser will not show any files!! Apparently, the input box text is saved somewhere when you close the application.

So, I cleared the match input box and voila! Problem solved.

share|improve this answer
    
Wow this was a huge headache for me until reading your answer. Also, in that state, if you try to create a new file you get the error "An error occurred while creating a new file: The new file is currently filtered out. You need to adjust your filter settings to make the file visible" –  Bryan Wolfford Aug 31 '13 at 2:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.