Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Somehow my flash drive is not showing on my desktop anymore. Maybe it wasn't disconnected properly. There is light on it so there is power but still not showing on my 2 x 3 GHz Dual Intel MacPro. Tried the disk utility and still it's not showing. Checked the Finder Menu-Preferences and the settings are fine. What to try next..anyone...?

share|improve this question
    
Do you use virtualization software on your Mac, like VMware Fusion? If a VM is running and the USB drive is connected to it the drive won't show up in the Finder nor in Disk Utility. Otherwise, I'd say the flash drive is broken (or your Mac's USB port). Even if the drive wasn't unplugged properly it should definitely be listed in Disk Utility. Have you tried plugging it in another computer? –  jaume Mar 14 '13 at 9:02
    
Thanx for responding..I don't use virtualization and I even tried on a different computer a Mac and a PC but still nothing. Guess it's really broken :( –  Jay Mar 14 '13 at 23:46
    
Open Applications>Utilties>Terminal, type sudo tail -f /var/log/system.log (type your password if asked), hit <kbd>Enter</kbd> a couple of times and then plug your flash drive. If you see timeout messages similar to this: ` AppleUSBEHCI[0xXXXXXXXX] ::Found a transaction past the completion deadline on bus 0xfd, timing out! (Addr: 6, EP: 2)` or this: USB to ATA/ATAPI bridge::terminate(kIOServiceSynchronous) timeout, or if you don't see USB messages at all, the drive is probably damaged beyond remedy. –  jaume Mar 15 '13 at 8:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.