Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an HP 566 with Windows 8 installed. I removed it, and I wanted to install Windows 7. I have problems installing Windows 7.

In BIOS I can choose two boot modes:

  1. Legacy boot mode
  2. UEFI boot mode

If I chose the Legacy boot mode for some strange reason all of my Windows CDs stop booting at a certain point.

If I choose UEFI mode I enter the installation process, but cannot install Windows on the drives because they are GPT type. I tried converting them using diskpart, and I got an error that disks cannot be converted.

How to proceed? I am really stuck here.

If it makes things easier, Windows XP can also be installed.

share|improve this question
    
You got me confused... You wrote: Windows 7 does not support booting to a GPT partition with UEFI boot mode and then the opossite :S –  fox Mar 14 '13 at 11:03
    
In UEFI I got an error that I cannot install on any drive because they are GPT. In legacy I could not even boot... –  fox Mar 14 '13 at 11:06
add comment

1 Answer

Windows locks its boot mode to its partition table type:

  • BIOS boot or installation works if and only if the disk is MBR
  • UEFI boot or installation works if and only if the disk is GPT

Therefore, if Windows complained that the disks were GPT, the installer was booted in BIOS mode, not in UEFI mode, no matter what boot mode you selected in the firmware. This can happen because some UEFIs use the boot mode you specify as more of a suggestion than a requirement; if you say "boot in UEFI mode," it'll try that, and if it can't, it will drop back to a BIOS-mode boot. My suspicion is that this is what's happened to you.

You could look for other firmware options related to the boot mode. Since the computer originally held Windows 8, chances are it had Secure Boot enabled, and that might explain the problem -- the firmware would try a Secure Boot with UEFI, fail, and then drop back to a BIOS-mode boot. (Really it shouldn't drop back to BIOS mode in that case, but I've seen other UEFIs do this.) If this hypothesis is correct, you may be able to fix the problem by going into your firmware and disabling Secure Boot. Unfortunately, the user interfaces vary so much that I can't say precisely how to do this; you'll just have to dig around until you find the appropriate option.

If that fails, you may need to tweak your installation medium, since they can be flaky on some computers. This can get a little tricky, but check the "Booting Windows Under DUET" section of this page. You can ignore the stuff on DUET (which is a way to run an EFI implementation as a sort of boot loader on a BIOS-based computer) and follow the numbered list for information on creating a bootable USB flash drive with the Windows installer. Copy the bootmgfw.efi file to EFI\BOOT\bootx64.efi to get it to boot automatically rather than manually selecting it, which DUET supports but your firmware might not.

share|improve this answer
    
Got it working. With diskpart I tried converting the disk to MBR and it was succesfull. –  fox Mar 15 '13 at 6:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.